Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a Lenovo Thinkpad X120e with Ubuntu 12.04 LTS 64-bit and a Gnome 3.4 (gnome-shell) desktop environment. I have installed the latest proprietary AMD drivers (From their website) for the AMD Radeon HD 6250 graphics card.

My problem is that once the mouse appears on the screen at startup, the backlight controls (Fn+Delete/Home) stop working. While it's booting up, I can control the brightness just fine. At first it wouldn't work at all, but turning off Vari-Bright in Catalyst Control Center fixed it. Once logged in the OSD works fine, but brightness control does not work, so it's no a keyboard shortcut issue. I have tried adding acpi_backlight=vendor, acpi_backlight=video, acpi_osi=Linux, acpi_osi=, and combinations of the two options to the grub config and they do not do anything (of course I ran grub-update). I have also tried adding Option "RegistryDwords" "EnableBrightnessControl=1" to the Device section of xorg.conf (I belive this is for Nvidia drivers, but doesn't hurt to try), and combined this with the grub configs, and this also does nothing.

I am running out of options here. It's not so bad, but quite annoying during the evening when I want to turn the brightness down.

Anybody know how to fix this?

share|improve this question

1 Answer 1

Try this:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Remove your xorg.conf file:

sudo rm /etc/X11/xorg.conf

Re-install xorg:

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

Configure xorg:

sudo dpkg-reconfigure xserver-xorg

Reboot:

sudo reboot

And that should work!

It is all here.

share|improve this answer
    
I know this is a bit late, but thanks. That laptop is not running Ubuntu anymore (Installed Win8 and gave it to someone) , but if I ever have this problem again, I'll know what to do. That said, I'm sticking to Intel from now on. –  Degru Mar 12 at 5:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.