Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Have a Virtual Box running Win7 inside an Ubuntu host - the guest does not connect to the internet, but the host does.

It is using an intel pro/1000 MT Desktop adapter with settings set to autodetect.

The IP config file reads:

Host Name . . . . . . . . . . . . : pm-PC Primary Dns Suffix . . . . . . . : Node Type . . . . . . . . . . . . : Hybrid IP Routing Enabled. . . . . . . . : No WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Desktop Adapter Physical Address. . . . . . . . . : 08-00-27-6F-3B-61 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : Yes Link-local IPv6 Address . . . . . : fe80::7d84:5fe5:a614:189a%11(Preferred) IPv4 Address. . . . . . . . . . . : 10.0.2.15(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Lease Obtained. . . . . . . . . . : Friday, 30 August 2013 10:24:35 AM Lease Expires . . . . . . . . . . : Saturday, 31 August 2013 10:24:35 AM Default Gateway . . . . . . . . . : 10.0.2.2 DHCP Server . . . . . . . . . . . : 10.0.2.2 DHCPv6 IAID . . . . . . . . . . . : 235405351 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-A7-5C-10-08-00-27-85-BD-42 DNS Servers . . . . . . . . . . . : 10.0.2.2 NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{D7033CB4-CF6A-4828-8004-6BD8242C3E58}:

Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Microsoft ISATAP Adapter Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:2048:166f:f5ff:fdf0(Preferred) Link-local IPv6 Address . . . . . : fe80::2048:166f:f5ff:fdf0%13(Preferred) Default Gateway . . . . . . . . . : :: NetBIOS over Tcpip. . . . . . . . : Disabled

Any suggestions?

share|improve this question
add comment

1 Answer

You should not have to do anything special to get internet to work in your guest, these are the settings that I have used for several years.enter image description here

Here is a link to networking for virtualbox that should help. networking

share|improve this answer
    
Thanks, yes, these are the settings I have, but cannot detect whether the problem is Win-based, VB-based, or Ubuntu.. so trying to trouble shoot the issue... –  Loligo Aug 31 '13 at 5:22
    
I added a link that should help. –  Wild Man Aug 31 '13 at 13:46
    
Thank you, I had seen the link and instructions, that is why I am asking for help - I can't see where I went wrong. –  Loligo Sep 3 '13 at 1:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.