Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Turns out this is called overscan / underscan problem.

so getting closer but still not perfect, with 3.9.0-030900-generic kernel

 xrandr --output HDMI-0 --set underscan on --mode 1920x1200

this way I can see my entire desktop, but there is a roughly 100 pixel black border wasting useful screen estate!

underscan-on

 xrandr --output HDMI-0 --set underscan off --mode 1920x1200

this way the desktop probably fills up the physical display, but I can not see it all as some parts of it goes "under" the black border

underscan-off

3.10.9 kernel does not have this underscan issue, but no HDMI audio, otherwise the video output is just black screen

Question is still, how to get the native resolution of the screen working properly with HDMI audio if possible.

Also tried 3.11-rc7 kernel, the overscanning / underscanning issue additionally there is no HDMI audio device - same kernel config

so seems like 3.10.9 is my best bet if I can live without the audio through hdmi

========

using Ubuntu 13.04 Raring

I had the OSS Radeon drivers configured with 3.9.0-030900-generic kernel which I compiled and it was working very well.

The card is an ATI Radeon 5770 connected to a ViewSonic VX2835wm 28” screen through HDMI, but the results were the same through the DVI interface as well.

I am not sure what happen, but after a few apt-get upgrades it stopped working properly - maybe it is something else than upgrades not sure. There might be something going wrong with the EDID of the screen not sure, see the bottom for some tests.

In the native resolution of the screen which is 1920x1200 the desktop would overlap the physical screen, without panning. So if you put a window in full screen the edges of the window would be off the screen on the top and the two sides.

Here are some visual mockup approximation of what I could achive. The Ubuntu caption at the login screen was cut off ... The only other option I could achieve with some tweaking was to have a black border around the screen either covering up the desktop or with a downscaled version of the desktop.

Either way it was not working properly. I tried a number of things, I can not recall them exactly but eventually I gave up and tried to install the proprietary fglrx Catalyst drivers.

After installing fglrx I tried the scaling options from the control panel. When it was set 'use graphics process for scaling', I could not select 1920x1200 only 1920x1080, when it was selected to scale with 'use display for scaling' I could select 1920x1200 but I had the same black border covering up desktop space and windows overlapping the visible are when maximized. I could get 1920x1080 working by tweaking the scaling bar Underscan/Overscan option but the text was blurry I was not happy with it, I wanted the native resolution.

I decided to go back to the OSS drivers and recompile a new version of the kernel 3.10.9. After doing so and purging fglrx as described on the help wiki of ubuntu I got a totally blank screen after boot. I tried ctrl-alt-backspace to restart X, tried ctrl-alt-f1 .. f6 to check text consoles all of them were pitch black. I booted the new kernel into recovery mode and after a few tries I managed to figure out that if I boot the kernel with appending the nomodeset option it boots into poor graphics mode, than I run modprobe radeon setmode=1 from a text console restart lightdm and Im good to login in 1920x1080, after that I could use xandr --output HDMI-0 --mode 1920x1200 and all works as expected. However I could not figure out how to configure the system to get everything working automatically at boot time, so after each reboot I have to do the dance.

xrandr -q now shows

Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 708mm x 398mm
   1920x1080      60.0 +
   1920x1200      60.0* 
   1920x1080i     30.0  
   1680x1050      59.9  
   1400x1050      59.9  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1152x864       75.0  
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   1440x480       59.9  
   1440x480i      30.0     30.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   720x480        59.9  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DVI-0 disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)

get-edid says:

*********** Something special has happened!
Please contact the author,...
EDID claims 1 more blocks left
EDID blocks left is wrong.
Your EDID is probably invalid.

while parse-edid says:

parse-edid: EDID checksum failed - data is corrupt. Continuing anyway.
parse-edid: first bytes don't match EDID version 1 header
parse-edid: do not trust output (if any).


    # EDID version 1 revision 3
Section "Monitor"
    # Block type: 2:0 3:ff
    # Block type: 2:0 3:fd
    # Block type: 2:0 3:fc
    Identifier "VX2835wm"
    VendorName "VSC"
    ModelName "VX2835wm"
    # Block type: 2:0 3:ff
    # Block type: 2:0 3:fd
    HorizSync 30-82
    VertRefresh 50-76
    # Max dot clock (video bandwidth) 150 MHz
    # Block type: 2:0 3:fc
    # DPMS capabilities: Active off:yes  Suspend:no  Standby:no

    Mode    "1920x1080" # vfreq 60.000Hz, hfreq 67.500kHz
        DotClock    148.500000
        HTimings    1920 2008 2052 2200
        VTimings    1080 1084 1089 1125
        Flags   "+HSync" "+VSync"
    EndMode
    # Block type: 2:0 3:ff
    # Block type: 2:0 3:fd
    # Block type: 2:0 3:fc
EndSection

dpkg -l | grep radeon

ii  libdrm-radeon1:amd64                      2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~raring                     amd64        Userspace interface to radeon-specific kernel DRM services -- runtime
ii  xserver-xorg-video-radeon                 1:7.1.99+git20130730.6a278369-0ubuntu0sarvatt~raring                   amd64        X.Org X server -- AMD/ATI Radeon display driver
share|improve this question
1  
hope you can add images now.. :) –  Saurav Kumar Aug 29 '13 at 7:22
    
ok so the black screen only with 3.10.9 kernel seems "normal" when radeon.audio=1 that is why it is disabled by default with this kernel the desktop fits the physical screen in 1920x1200 perfectly, but no sound through HDMI<br/> <br/> I booted the old kernel 3.9.0-030900-generic and hdmi audio works, with this kernel the desktop ovarlays the physical screen in 1920x1080 and there is a black border covering useful area in 1920x1200, but there is sound through HDMI How can I have best of both worlds? –  Feczo Aug 29 '13 at 8:35
    
added the images, thanks –  Feczo Aug 29 '13 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.