Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The new Gnome 3.0 requires hardware acceleration support. I wanted to try it out -- but how do I tell whether hardware acceleration is supported on my machine?

share|improve this question
up vote 18 down vote accepted

Gnome-Shell has very similar graphical requirements as the Unity interface. Therefore, if you want a quick test of potential compatibility, you could run the unity graphical test application via a live CD:

/usr/lib/nux/unity_support_test -p

If you get a picture similar to this with all "yes" values - you probably can assume Gnome-Shell will work.

enter image description here


Linked Question:

  1. What do the "no"s mean, in the output of unity support test?
share|improve this answer

Well the best way of course is to just try it out ;)

Try a quick search through the ubuntu forums for you computers model number.

And the Ubuntu-certified hardware list might help as well.

share|improve this answer

Do you have Firefox installed?

Well, then here's a quick and dirty way without messing around in console at all:

Hit about:support in URL bar, and scroll down to Graphics table (below Extensions).

Surely, it's not as specific as the unity_support_test script, but it did the trick for me anyway. For one the Device ID and Driver Version lines are already fairly descriptive; furthermore, you can bet your life on it that if it got blacklisted in FF, it will be prone to errors and rendering trouble in Unity as well.

Oh, and the very last line is also a great information: CairoUseXRender. It's a 100% rule that whenever this is a 0, one of the first applications ever programmed on X Window, xclock, will not render the clock hands correctly as well!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.