Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have an Acer Aspire One 532h. That I have installed Ubuntu 12.10 on to a 32x. Before it was running 10.10 and the wifi was working fine until after the update. The first thing is did I ran lshw which returns with:

network UNCLAIMED
AR9285 Wireless Network Adapter

I will say I am running a portable hotspot from Verizon so I can't focus on the Ethernet port. I have done some research on the fact that the drivers are missing. To prove as well I will show you some of the things I have tried:

(1) rfkill list

(2) I have downloaded backports-3.11.rc3-1.tar.bz2 which i have no Idea how to install.

(3) I have also tried this:

Here are the step-by-step instructions:

Download a stable driver from this link. Copy the downloaded file in your Home directory. Open a terminal and run the following commands:

tar xf compat-wireless-3.1.1-1.tar.bz2

cd compat-wireless-3.1.1-1

./scripts/driver-select ath9k

bash ./scripts/driver-select: No Such File or directory

make

sudo make install

sudo make unload

Restart your computer.

Done!

After this I restart the comp and nothing changes. Any help as to what I am doing wrong

share|improve this question
    
I believe your device is covered by ath9k without compiling. Let's check your device: lspci -nn -d 168c: Does it spring to life if you do: sudo modprobe ath9k? –  chili555 Aug 28 '13 at 22:10
    
I tried sudo modprobe ath9k and it returns with ignoring bad line starting with 'option' as for the first line of code you suggested it returned with: lspci -d ":" expected. Also want to add i tried lsmod |grep mac80211 followed by echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf which returns with option ath9k nohcrypt=1 –  Howard Aug 28 '13 at 23:55
    
Are you sure that you entered the entire command as I asked for it? lspci -nn -d 168c: <---the complete sequence on one line. What is the exact error for: sudo modprobe ath9k? –  chili555 Aug 29 '13 at 12:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.