Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please help me to find out why its not working

root@icloud_mail# sudo apt-get install slapd ldap-utils
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libodbc1 libslp1
Suggested packages:
  libmyodbc odbc-postgresql tdsodbc unixodbc-bin slpd openslp-doc
The following NEW packages will be installed:
  ldap-utils libodbc1 libslp1 slapd
0 upgraded, 4 newly installed, 0 to remove and 284 not upgraded.
Need to get 2,243 kB of archives.
After this operation, 5,595 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Err http://us.archive.ubuntu.com/ubuntu/ quantal/main libodbc1 i386 2.2.14p2-5ubuntu4
  Could not connect to 172.19.48.164:8080 (172.19.48.164). - connect (110: Connection timed out)
Err http://us.archive.ubuntu.com/ubuntu/ quantal/main libslp1 i386 1.2.1-9
  Unable to connect to 172.19.48.164:8080:
share|improve this question
2  
Fix your proxy configuration. –  dobey Aug 28 '13 at 21:16
2  
Close voters: Where is the indication that this problem went away and cannot be reproduced? @dobey I recommend posting an answer explaining how to do that, or a link to a duplicate that has an answer, or at least some additional information. Most people who ask for help here with those error messages wouldn't know how to fix their proxy settings. –  Eliah Kagan Aug 30 '13 at 15:34
    
@EliahKagan The "this is an isolated case only for this user" option in the close votes is no more. It appears to now be part of the "the problem went away" vote option, if you read the full description of it. As for fixing the proxy configuration, one must have configured it already for it to be broken, therefore one should already know where to go to fix it. If one doesn't know how to configure their proxy, it would be extremely unlikely for the to have broken proxy configuration. The IP address shown is not the one assigned to us.archive.ubuntu.com. And port 8080 suggests it is a proxy. –  dobey Aug 30 '13 at 17:14
1  
@dobey Lots of people don't remember how they configured their proxy settings, and lots of people got help or had someone else do it. As for the "the problem went away" close reason, it is not intended as a full replacement for "too localized." Its wording makes clear that it's only for questions that are relevant only for a narrow period of time. The "too localized" close reason was removed specifically because it was being abused for questions like this one. –  Eliah Kagan Aug 30 '13 at 17:32
    
I'm not sure how "I don't remember how I broke my system" is a problem for ask Ubuntu. This question is clearly "too localized" as it is specific to this machine attempting to connect to this proxy it is configured for, and not a general Ubuntu problem. If there is a question it would be a duplicate of, then that's fine. I don't have time to go through the 100s of "apt failed" questions to find it though. The problem is that almost all of them are poorly worded, and too localized, and thus not easy to find or necessarily helpful to others. –  dobey Aug 30 '13 at 21:03
add comment

1 Answer

Apparently, your APT configuration is set to connect using a proxy server. This server cannot be reached and that is what the error is about. How do we know that? Well, it should not connect to a local IP address for the Ubuntu mirror for downloading the packages. The combination with the connect to port 8080 instead of plain HTTP on port 80, this is behaviour of APT that can only be caused by proxy configuration settings.

I assume your proxy server isn't online anymore and you don't want to use it anymore.

  1. Find the configuration line responsible for it:

    grep -rni proxy /etc/apt
    
  2. The results will list something like

    /etc/apt/apt.conf:1:Acquire::http::Proxy "http://1.2.3.4:8000/";
    

    What you see here is that in the file /etc/apt/apt.conf on line 1 APT is configured to connect using that proxy address. On your system filename and line are likely to be different.

  3. Edit the file with the line. Comment it (prepend it with a hash #) or simply remove the line. Use a text editor, e.g. nano (or any other of your preference):

    sudo nano /etc/apt/apt.conf
    
  4. Save and close.

  5. Update the APT lists:

    sudo apt-get update
    

Happy updating/installing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.