Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have come across an interesting problem. I've got an Asus K55VD with an Nvidia 610M graphics card.

I did a clean install of 12.04 off a live CD. During my first use, I chose to install the proprietary drivers. During the same session I did a complete update of my system, some 650 updates in total. When I did all the restarting, my default session has seemed to change to Unity 2D. When I run echo $DESKTOP_SESSION, I get Ubuntu-2d.

This happens even when I start the session by choosing 3d. It's not a super huge deal, but I'd like to be able to run in 3d. It won't let me change the size of the launcher, and I'm really annoyed at having the buttons so large.

I have tried to get rid of the proprietary drivers, but my computer says now that it's not using any.

Any advice? Thanks!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Figured it out. I purged all nvidia drivers and it fixed it!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.