Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've got a Dell Latitude E6530 here which is Nvidia Optimus enabled. In Ubuntu 12.04 I installed:

  • nvidia-319
  • Bumblebee stable PPA version 3.2.1-1~preciseppa4 installed with the instruction from https://wiki.ubuntu.com/Bumblebee
  • Raring hardware enablement kernel+Xorg (by default on 12.04.3 new install)

Works perfectly fine for one boot after installation. Each boot following the first will result in a black screen. I've nailed it down to a resetting option in the BIOS of the Dell machine: after installing Bumblebee and booting for the first time with it, it will disable it in the BIOS. The option "Enable Optimus" is unticked, magically.

This means I have to re-enable Optimus in the BIOS before I boot Ubuntu every single time. Running an OS without Bumblebee does not reset the Optimus setting in the BIOS. How can I prevent Bumblebee from touching the settings in the BIOS?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Using Ubuntu 13.04 and Nvidia 325.x driver from the Xorg-edgers PPA, I don't see any issue anymore.

Also make sure not to use any brightness fixing methods which seem to be needed with Nvidia proprietary driver < 325. So, remove any of the acpi_osi=Linux and acpi_backlight=vendor kernel parameters, otherwise bbswitch will complain about a missing ACPI handle for the discrete graphics card and won't be able to actually switch graphics.

With acpi_backlight=vendor (idle power consumption 22W+):

Sep  2 01:17:59 gert kernel: [   12.999284] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
Sep  2 01:17:59 gert kernel: [   12.999292] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.VID_
Sep  2 01:17:59 gert kernel: [   12.999782] bbswitch: failed to evaluate \_SB_.PCI0.GFX0._DSM {0xA0,0xA0,0x95,0x9D,0x60,0x00,0x48,0x4D,0xB3,0x4D,0x7E,0x5F,0xEA,0x12,0x9F,0xD4} 0x102 0x0 {0x00,0x00,0x00,0x00}: AE_NOT_FOUND
Sep  2 01:17:59 gert kernel: [   12.999785] bbswitch: No suitable _DSM call found.
Sep  2 01:17:59 gert bumblebeed[1953]: Module bbswitch could not be loaded (timeout?)

Without acpi_backlight=vendor (idle power consumption 10-11W):

Sep  2 08:23:53 gert kernel: [    9.609896] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
Sep  2 08:23:53 gert kernel: [    9.609901] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.VID_
Sep  2 08:23:53 gert kernel: [    9.610153] bbswitch: detected an Optimus _DSM function
Sep  2 08:23:53 gert kernel: [    9.610168] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
Sep  2 08:23:53 gert kernel: [    9.611411] bbswitch: disabling discrete graphics

The upgrade to 13.04 also fixed other minor issues and it seems the machine is running a lot better now in terms of power management.

share|improve this answer

Setting TurnCardOffAtExit to false in /etc/bumblebee/bumblebee.conf fixes the issue. The card will not be turned off during shutdown.

More info: https://wiki.archlinux.org/index.php/Bumblebee#Enable_NVIDIA_card_during_shutdown

Hardware details of Dell E6530: http://hw.rosalinux.ru/index.php?probe=bab3304e66

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.