Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to Install Broadcom Wireless card (BCM43XX)

I am currently using Ubuntu 10.10 on my laptop , the model of my wireless chip is broadcom BCM4312 802.11b/g LP-PHY .

I tried to activate the driver for the chip by going to System -> Administration -> Additional Drivers and activated Broadcom STA wireless driver. But the laptop can't detect any wireless signal still.

Do I have to do any additional work to make the chip work ? Or how can I test if there is physical damage to the chip itself?

share|improve this question

migrated from superuser.com Apr 6 '11 at 23:52

This question came from our site for computer enthusiasts and power users.

marked as duplicate by Luis, RolandiXor, Mik, Stephen Myall, Jorge Castro Nov 14 '12 at 19:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Is the computer already plugged in via Ethernet? –  digitxp Jan 7 '11 at 22:22

3 Answers 3

I have BCM4312 and 10.10 as well. You might want to try reinstalling the drivers, given that you have already restarted the computer to see if you receive a wireless signal. In a terminal:

sudo aptitude remove bcmwl-kernel-source

to remove the drivers and

sudo aptitude install bcmwl-kernel-source

to install them again. Restart and see if they are enabled/activated in your 'additional drivers' menu.

share|improve this answer
    
I think it solves the problem. –  piyushnp Oct 24 '11 at 20:47
    
It solved my problem! ;D –  piyushnp Oct 24 '11 at 21:02

(if the method above doesn't work - resolve "firmware missing" problem) There's no need for ndiswrapper and Windows drivers, because the Linux driver already exists.

  • If you don't see broadcom wireless device name, uninstall driver, restart computer, install driver and restart again until "firmware missing" message appears with wifi device name under wireless icon after clicking on it (gnome).

  • If you haven't it, you must install a synaptic package manager from Ubuntu software center

  • search "bcm" inside synaptic package manager

  • mark for installation b43-fwcutter, firmware-b43-lpphy-installer, firmware-b43legacy-installer and apply, no restart needed. Your Wi-Fi led turns on immediately.

share|improve this answer

I believe you problem can be solved in a similar way to mine I had some time ago. See the answer to this question for the steps I took to resolve it.

Broadcom BCM4401-B0 100Base-TX Issues

share|improve this answer