Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to find what graphics card I'm running, the commands in terminal only gives me this:

VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller. 

How do I install the correct driver? As I can see that not everything is displaying correctly. I want to set a proper resolution, but can't as I don't have the right drivers on my Ubuntu 12.04 machine. It's an Acer Aspire One netbook.

share|improve this question
    
Which Ubuntu version you are using? Please reply.. Or edit your question and reply with your Ubuntu OS! –  Saurav Kumar Aug 28 '13 at 17:01
    
Hi, I'm using ubuntu 12.04 LTS –  Orosjopie Aug 28 '13 at 17:07
    
Thanks for your reply.. Before reading your comment, I've posted one answer.. Hope it will work for you!! –  Saurav Kumar Aug 28 '13 at 17:13
add comment

3 Answers

Download the Intel graphics card installer.

The Intel Linux Graphics Installer allows you to easily install the latest graphics and video drivers for your Intel graphics hardware. This allows you to stay current with the latest enhancements, optimizations, and fixes to the Intel® Graphics Stack to ensure the best user experience with your Intel graphics hardware. The Intel® Linux Graphics Installer is available for the latest versions of Ubuntu and Fedora.

Once downloaded, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, navigate to the downloads folder, and run the command(s) below:

sudo dpkg -i <package_name>.deb

Once installed, run the installed app, and it will detect, and download the right driver for you.

Edit

This driver file has been tried on 12.04 fully updated, and it worked OK, but if for any reason it gives an error or a problem you can download version 1.0.1 here. Keep in mind this is the 32bit version.

Edit 2

Try this, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-add-repository ppa:glasen/intel-driver
sudo apt-get update
sudo apt-get install xserver-xorg-video-intel

Source:Intel

share|improve this answer
    
Hey Mitch! Intel Linux Graphics Installer is for Ubuntu 12.10 and higher! He is using Ubuntu 12.04. I have also suggested this before he replied that he was using Ubuntu 12.04 LTS. So suggest some other way, if possible!! –  Saurav Kumar Aug 28 '13 at 17:25
    
@SauravKumar I tried it on 12.04, and it works. –  Mitch Aug 28 '13 at 17:29
    
Thanks, how do I navigate terminal to the downloads folder to run this command? –  Orosjopie Aug 28 '13 at 17:33
    
Once you open terminal, do cd Downloads –  Mitch Aug 28 '13 at 17:36
    
may be you have tried the older version. Now you'll be able to install verson 1.0.2 which doesn't support 12.04 LTS :( I tried it and while scanning I always get an error "distribution not supported". My version is 1.0.1. If you have older .deb file please send it on my email address: saur.k10@gmail.com –  Saurav Kumar Aug 28 '13 at 17:36
show 4 more comments

Here are the ways to install Intel Graphics Card Driver

1. If you are using Ubuntu 12.10 or higher, then you don't have to worry, as Intel has
 released a software for Linux system which will scans your graphics card and try to 
 install appropriate graphics driver. Please refer following link:

https://01.org/linuxgraphics/downloads/2013/intelr-linux-graphics-installer-version-1.0.2

2. If you are using Ubuntu 12.04 or less then you can always install you graphics driver
by running these command:

    $ sudo apt-get update
    $ sudo apt-get install xserver-xorg-video-intel

3. You can also give a try to this:

    $ sudo (jockey-gtk &)
As it will scan all your available drivers and try to install the missing one.

4. If nothing works then finally install latest driver by following these steps:
  • Open Ubuntu Software Center.
  • From the top-level menu, select Edit | Software Sources ... .
  • Select the Other Software tab.
  • Click the Add ... button.
  • Enter the following: deb https://download.01.org/gfx/ubuntu/12.04/main
  • Click the +Add Source button.
  • Provide your user password when requested.
  • Click the Close button.
  • Update and install by executing following commands:

    $ sudo apt-get update
    $ sudo apt-get install xserver-xorg-video-intel
    

Hope it will work for you!

share|improve this answer
    
I've tried what you suggested above, but for what I can see is that I already have the up to date drivers. If so,why do I have to zoom out in a web page for example to be able to see the page properly? If I do not zoom out, pages appears in 800x600 resolution. And I can only use this resolution. What else can I do? –  Orosjopie Aug 28 '13 at 17:36
    
Then I suggest you to install latest graphics driver from repository. I am editing my answer and adding one more option to install latest from repository.. If it doesn't work then I will tell you what I have done to fix my problem. May it help you. –  Saurav Kumar Aug 28 '13 at 17:42
add comment

What you ran was lspci | grep -i vga that effectively gives you that "video card". You are already using the appropriated drivers for your system. If you want to see the kernel driver you should use lspci -knn | grep -A2 VGA

lspci -knn | grep -A2 VGA 
03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV515 [Radeon X1300/X1550] [1002:7146]
    Subsystem: VISIONTEK Device [1545:2352]
    Kernel driver in use: radeon
                          ^^^^^^

As you can see, that is my "driver" for my dedicated video card. In your case it shows like that since recently Intel now includes GPU properties in their CPU. So the output is correct.

If you are having problems with your current drivers, is probably a bug, and as such it should be reported in LaunchPad. In AskUbuntu is there a guide to do so.

share|improve this answer
    
thanks. is there a way for me to install the kernel drivers? –  Orosjopie Aug 28 '13 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.