Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated my laptop from Ubuntu 12.04 to 12.10. After the update I could no longer get to the login screen, and after a while I realized that during the update my nvidia-drivers had been uninstalled. Apparently no other graphics driver is available.

So I started a root prompt to install nvidia-current only to find out that my internet connection is gone. I did the whole update with an ethernet cable plugged in, so it obviously worked in 12.04.

I tried to run /etc/init.d/networking start and service networking start to no avail.

ifconfig -a only shows the lo interface (Local Loopback).

lspci lists my ethernet controller:

04:00.0 Ethernet controller: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)

I found some resources on the net suggesting I add

auto eth0
iface eth0 inet dhcp

to /run/network/interfaces (which didn't exist), so I did that and retried service networking start. However, it still doesn't work.

How do I make Ubuntu 12.10 recognize the ethernet connection?

Edit: I just ran lshw -C network which lists both my ethernet and wireless as UNCLAIMED. I heard this means there are no drivers available. I have a USB-drive with 12.04 on it, can I somehow extract the correct driver from there and install it?

share|improve this question
add comment

1 Answer

I started the root prompt from recovery mode in the oldest version of all installed kernels. That was a bad idead. I tried recovery mode with the newest kernel and ethernet started working. From there on I could install nvidia-current, and now I'm all set!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.