Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with ubuntu-sdk

I installed it following the guide here Get-Started

But then when I start ubuntu-sdk and try tro create a new project I can only choose "Other Projects", "Non-Qt Project" and "Import Project", but "Projects > Ubuntu " simply does not exist.

To Install Ubuntu SDK I ran the following commands:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo apt-get install qtcreator
sudo apt-get install ubuntu-sdk

I'm running Ubuntu 13.04 32-bit

Anyone can help? Thank You.

Here's a screen:

Ubuntu SDK

share|improve this question
up vote 2 down vote accepted

The actual solution instead of installing 12.04 is as fallow:

Go to Tools/Options/Build & Run -> Qt Versions Click on "Add..." and navigate to this path /usr/bin/qmake

So it should look like this: Qt Versions

Then set it as the default version for the "Desktop" kit (Build & Run -> Kits).

So it should looks like this: Kits

After that just restart Qt Creator and you should be good to go.

share|improve this answer

In the Write your first app step (actually the next one), is included a link to the phone app tutorial which follows this steps:

  1. In Qt Creator, press Ctrl + N to create a new project (here is where you are)
  2. Select the Projects > Ubuntu > Simple Touch UI template and click Choose… (I'm guessing that "Ubuntu" is scrolling down the list)
  3. Give the project CurrencyConverter as a Name. You can leave the Create in: field as the default and then click Next.
  4. You can optionally set up a revision control system such as Bazaar in the final step, but that’s outside the scope of this tutorial. Click on Finish.
  5. Replace the Column component and all of its children, and replace them with the Page as shown below, and then save it with Ctrl+S: (here is a bunch of code, which is not important for solving the problem)
share|improve this answer
Thanks for your answer, but the problem is that "Projects > Ubuntu " simply does not exist.. I can only choose "Other Projects", "Non-Qt Project" and "Import Project".. – carlduke Aug 28 '13 at 14:41

Okay, I just solved it this way:

I removed Ubuntu 13.04 and Installed Ubuntu 12.04.3 LTS, Then I ran:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo apt-get update
sudo apt-get install qtcreator
sudo apt-get install ubuntu-sdk

Now everything seems to be fine.

enter image description here

Thanks to everyone for the help!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.