Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install knife-cloudstack plugin using gem install on Ubuntu 12.04 with chef-client configured and got error as said in title.

>gem install knife-cloudstack
ERROR: Error installing knife-cloudstack:
       gssapi requires Ruby version >= 1.9.1

So i tried installing apt-get install ruby1.9.3, but still the same error.

Also, the version of ruby is shown 1.9.3

ruby --version ruby 1.9.3p0 (2011-10-30 revision 33570) [i686-linux]

To get more confused, when i run sudo update-alternatives --config ruby , its showing output as:

There are 2 choices for the alternative ruby (providing /usr/bin/ruby).

     Selection    Path                Priority   Status
     0            /usr/bin/ruby1.8     50        auto mode
     1            /usr/bin/ruby1.8     50        manual mode
   * 2            /usr/bin/ruby1.9.1   10        manual mode

   Press enter to keep the current choice[*], or type selection number:

PS: Initially the * was on Selection:0, i changed it later to 2.

Now where is ruby1.9.3? Even if i installed ruby1.9.3, why its taking other version?Anyone knowing what's causing the issue?


share|improve this question

Removed ruby 1.8 from my system by that was the only one I had.

sudo apt-get purge ruby
sudo apt-get install ruby1.9.3


gem install knife-cloudstack #(knife-vcloud for me)

worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.