Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When trying to activate the wireless driver, I get it could not be activated. It says to check the logs. I am a complete noobie to ubuntu and am generally trying to learn more about computers as I go. Here is the log. Any help would be extremely appreciated. My ethernet connection works fine, if that makes any difference.

tail -f /var/log/jockey.log

2013-08-27 21:52:41,104 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 21:52:41,129 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 21:52:51,349 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 21:52:58,681 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2013-08-27 21:52:58,681 WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver
2013-08-27 21:52:58,750 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 21:54:07,963 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 21:54:07,980 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 21:54:08,004 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 22:07:53,899 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 22:07:59,045 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2013-08-27 22:07:59,046 WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver
2013-08-27 22:07:59,088 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 22:08:13,260 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 22:08:13,282 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-27 22:08:13,318 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

lspci

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550]
02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series]
04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

sudo lshw -c

Hardware Lister (lshw) - B.02.15
usage: lshw [-format] [-options ...]
       lshw -version

    -version        print program version (B.02.15)

format can be
    -html           output hardware tree as HTML
    -xml            output hardware tree as XML
    -short          output hardware paths
    -businfo        output bus information

options can be
    -class CLASS    only show a certain class of hardware
    -C CLASS        same as '-class CLASS'
    -c CLASS        same as '-class CLASS'
    -disable TEST   disable a test (like pci, isapnp, cpuid, etc. )
    -enable TEST    enable a test (like pci, isapnp, cpuid, etc. )
    -quiet          don't display status
    -sanitize       sanitize output (remove sensitive information like serial numbers, etc.)
    -numeric        output numeric IDs (for PCI, USB, etc.)

rfkill list all

Doesnt return anything. Perhaps something here is the issue? It isn't picking up and available connections. I have a hard block button which I don't believe to be the problem on my laptop and have checked in boot settings to make sure wireless connections are enabled.

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.3 LTS
Release:    12.04
Codename:   precise
share|improve this question

marked as duplicate by Luis Alvarado Jan 21 at 5:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please Edit your question and include result of lspci, sudo lshw -c network & rfkill list all. Also include result of lsb_release -a.. may be this is the issue? But don't try unless you are very sure Broadcom STA driver fails to install missing wl on Ubuntu 12.04.3 LTS / Linux 3.8 –  Web-E Aug 28 '13 at 5:20
    
run this command it your terminal.. It will scan your all drivers and try to fix it, also if any proprietary drivers used, you can do some changes like enable/disable: $ sudo (jockey-gtk &) Post your comment here after that. –  Saurav Kumar Aug 28 '13 at 5:23
    
@SauravKumar The log above is from jockey –  Web-E Aug 28 '13 at 5:42
    
Yes I know. I just wanted to know if he tried to use jockey or not as graphical tool. –  Saurav Kumar Aug 28 '13 at 5:44
    
You didn't enter this command correctly sudo lshw -c network –  Web-E Aug 28 '13 at 8:09

2 Answers 2

Please follow like below,

First execute following commands to install the packages

sudo apt-get install linux-libc-dev libc6-dev linux-headers-generic linux-headers-$(uname -r)

Now open the additional driver and try to reactivate the driver. If success reboot and check. If it succeeded and on reboot your hardware is still not functioning try rfkill unblock all.

If activation fails, execute below commands,

sudo apt-get remove --purge bcmwl-kernel-source - if it fails don't worry

next

sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer

Reboot again and retry.

Answer extracted from -How to Install Broadcom Wireless Drivers . You can explore if you want.

share|improve this answer

I am a new user of Ubuntu 13.10 and new to Linux anything. The below worked on my card [14e4:4312] in Dell M6300 except with

firmware-b43-lpphy-installer

replaced by

firmware-b43-installer

Apparently the -lpphy part has been superseded.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.