Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the error message I get when I try and launch google chrome:

The profile appears to be in use by process 2137 on host Brandon PC.
If you are sure no other processes are using this profile, delete the file
/home/brandon/.config/google-chrome/SingletonLock and relaunch Google Chrome. 

How do I fix this?

share|improve this question
    
Did you try to reboot? –  Symin Aug 27 '13 at 19:44
3  
Did you do what the message said to do? –  dobey Aug 27 '13 at 20:04
    
Yes I have tried but I can not find the folder the file is in. –  Brandon Morgan Aug 28 '13 at 4:20

1 Answer 1

up vote 2 down vote accepted

Executive Summary

You were probably unable to find the folder containing the SingletonLock file because it is inside the .config folder, which is hidden because it starts with a dot. Ctrl+H shows hidden folders.

It is best to make sure you're not running any chrome or chromium-browser processes though, before manually deleting that file. You can use the System Monitor for this, or the ps and killall commands. (Actually there are other ways too, but those ways are covered below.)

First make sure Google Chrome is not actually running anymore.

You can use the System Monitor for this. Press the Super key (i.e., the Windows key) and type system monitor. The System Monitor should come up as a search result. Click on it. It works pretty intuitively; it's similar to the Task Manager in Windows.

Go to the Processes tab in the System Monitor. Right-click on any chrome or chromium-browser processes you find, and click End Process. If that doesn't get rid of them, use Kill Process (which is right under End Process).

Screenshot of gnome-system-monitor, about to end or kill a chrome process.

If you find it in the System Monitor but are unable to quit it from there, or if you just prefer using a command-line, you can use the ps and killall commands as described below. One advantage of this way is that you can easily copy all the text from the Terminal and put it into your question (or a comment if it's very short), if you need help.

Forcing Chrome to quit, from the command-line.

If you've already used the System Monitor method described above, and either no chrome or chromium-browser processes were running or you were able to quit all of them, then skip this section.

Open a Terminal window (Ctrl+Alt+T) and run:

ps x | grep [c]hrom

That should show if Google Chrome (or Chromium) is running. Processes called google-chrome are Google Chrome; processes called chromium-browser are Chromium. Either could be accessing the lock file and preventing new instances of Google Chrome from launching properly.

You might see nothing at all. If you see nothing, then Google Chrome is not running. (At least not as your user account. ps ax would show processes for all user accounts ...but that should not be necessary.)

If Chrome is running, you might see something like this (possibly with more lines--sometimes with many more):

ek@Kip:~$ ps x | grep chrom
26563 ?        Sl     0:06 /opt/google/chrome/chrome

If any Chrome or Chromium processes are running, but there are no windows for them, then they're probably frozen. One good way to terminate them is by running this for Google Chrome:

killall chrome
killall -KILL chrome

(Use chromium-browser to kill Chromium.)

If you run the first command, then wait a couple seconds before the second command, Chrome might have a chance to unload somewhat cleanly.

If the first command succeeded, then when you run the second command you should see:

chrome: no process found

If you don't see that, run the second command again. If you still don't see it, then run:

sudo killall -KILL chrome

(This is okay so long as no other users are logged in and running Chrome. If they are, their instances of Chrome will be killed too.)

If you run that a couple times and still don't get a no process found message, then Chrome is probably caught in uninterruptible sleep. The best generally effective way to deal with that is to reboot your computer.

If this still happens when Google Chrome is not running...

...then it's time to follow the instructions it gave, and delete the lock file.

Given your description, this is actually likely. But it's good to make sure Chrome isn't actually running first (hence the section above).

The file to delete is:

/home/brandon/.config/google-chrome/SingletonLock

You said you couldn't find the folder it's in. Most likely, you were unable to find it because the .config subfolder of your home directory (/home/brandon) is hidden. Files and folders whose names start with a . are hidden by default.

If you want to delete the file in Nautilus (the file browser), you can press Ctrl+H or click View > Show Hidden Files. This shows entries that start with a . (and any other files configured to be hidden; usually there are no others).

Then you can navigate into the .config folder, into the google-chrome subfolder, and delete the SingletonLock file.

Alternatively, you an delete the file from the Terminal (Ctrl+Alt+T) with a single command:

rm /home/brandon/.config/google-chrome/SingletonLock

Do not use the -r or -R flag for this command. It's unnecessary, and if you typed the name of the file wrong, then it could delete lots of stuff you don't want deleted. (If you typed everything else correctly, it would be fine. But there is no advantage.)

That should fix the problem. If it does not, make sure the file was actually deleted and (if not) check its permissions. This one command will do both, and you can edit your question to include all the text in the Terminal from running it:

ls -l /home/brandon/.config/google-chrome/SingletonLock

(-l is a lower-case -L, not a numeral -1 or an upper-case -I.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.