Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Asus N53SN computer which has nvidia optimus. Rift online is working on my ubuntu but its using intel card. i need to make it work with geforce. But optirun wine riftpatcher.exe saying to me ;

wine: cannot find L"C:\windows\system32\riftpatchlive.exe"

so how can i make it work with geforce? and one more thing since rift has launcher and client separately ,is geforce going to work with client too?

im new to ubuntu .. thanks

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I believe you are not specifying the correct path for your application. Rift online is most likely not installed in your system32 folder (where is where wine will search by default if no absolute path is specified).

Check where it is installed on your virtual hard drive (C:) and type in that path

For Example:

optirun wine "C:\program files\riftpatch\riftpatchlive.exe"

Also if you are using bumblebee, i would suggest you install also primusrun (it is included with the same ppa you installed bumblebee with). Primusrun gives much better performance than using the optirun command and often solves problems that would be present using optirun.

sudo apt-get install primus

Then run the command with primusrun.

primusrun wine "C:\program files\riftpatch\riftpatchlive.exe"
share|improve this answer
    
Thanks! its working now –  serhan Aug 27 '13 at 18:41

I'll be honest, I tried primusrun but the performance is terrible compared to optirun. I get 65fps if I use primusrun on glxspheres and I get 178fps using optirun.. Anyway each to their own as the Optimus technology is still evolving.. Don't forget to export the GLX libraries when using optirun

export LD_LIBRARY_PATH=/usr/lib/nvidia-325:$LD_LIBRARY_PATH

(Note that the nvidia-325 is the driver i currently have installed, depending on what version of the nvidia driver your entry above will look a little different)

share|improve this answer
    
Primusrun normally has vsync enabled. Try running vblank_mode=0 primusrun glxspheres and it should outperform optirun. –  AbuBakr Mar 22 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.