Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello i was trying to update my apt-get. And its giving me this error

Err raring Release.gpg       
  Could not connect to (, connection timed out
Err raring-updates Release.gpg
  Unable to connect to
Err raring-backports Release.gpg
  Unable to connect to
Reading package lists... Done
W: Failed to fetch  Could not connect to (, connection timed out

W: Failed to fetch  Unable to connect to

W: Failed to fetch  Unable to connect to

W: Some index files failed to download. They have been ignored, or old ones used instead.

I am not a ubuntu master but i can understand this is not a computer error. Any guess how to fix this?

share|improve this question
This happens when my internet is down. Is your internet working? – Aaditya Bagga Aug 27 '13 at 16:02
yes, working. Its just happening with one of the update. BTW, how to post this if i dont have internet? – Fandango Aug 27 '13 at 16:05
Your configured Ubuntu archive mirror ( appears to be down. Select another mirror. Please refer to How do you select the fastest mirror from the command line? and How can I get apt to use a mirror close to me, or choose a faster mirror? on how to do that. – gertvdijk Aug 27 '13 at 16:10
Probably that server ( is having some problems. You can go to "Software & Updates" (in 13.04) and choose adifferent server. – Salem Aug 27 '13 at 16:11
up vote 7 down vote accepted

The server is just not responding right now. Try another server.

Go to System Settings, and click on Software and Updates. On the first tab, locate the dropdown labelled Download from and choose another location for your downloads, or Main Server.

share|improve this answer

You are going to smack yourself in the head over this but you probably aren't connected to the Internet.

If that is not true then you'll want to find a better repository to grab your packages from (because you're timing out to the one you have). Fortunately, Ubuntu has your back here. Changing the source server you use is really easy and automatic. Follow these instructions (for Gnome):

  • Open up System|Administration|Software Sources, and then select the "Download from: "Other".
  • Click on "Select Best Server". That will go through all of the servers/mirrors and ping each one.
  • It will then come back and tell you which one it got the best response from.

In Kubuntu it's a little different:

  • Open the application Muon Software Center (use the search on the start menu if you're having trouble finding it)
  • In the settings menu select 'Configure Software Sources'.
  • In the dialog you'll see a 'Download From...' dropdown. Use this to select a different repository.

A full tutorial is available on this subject in case you are having troubles with this:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.