Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

So I have a problem with my asus computer: everything went just fine until today, my computer shows me the grub menu when I start up like it usually does. But when I choose a version of linux the only thing I get is a purple screen or a black one if I use the recovery mode.

I have been using ubuntu 12.04 for about a month and I did not download a single update the day before it started to act like this. It was also running perfectly fine on start up until today.

I tried to replace quiet splash with nomodeset but that didn't help, running an older version of linux didn't help either, as I have the same problem on every version.

I have an Asus motherboard 8 Gb DDR3 Ram Nvidia GTX 560 graphics card Intel i7 quad core processor

(Someone posted a similar question here: Ubuntu 12.04.2 LTS boots to purple screen but nobody answered :/)

Edit Boot repair didn't solve the problem, here is the link it gave me: http://paste.ubuntu.com/6033493/

Second Edit: ctrl alt delete who worked before the boot repair doesn't work anymore... :/ (I could use it when I had the purple/black screen)

3th edit: The Grub commandline works, so maybe it's a problem with graphics? (Even though I didn't change anything when I last used my laptop on Ubuntu..)

Last edit: Seems like this was marked as a duplicate, the answers provided didn't solve the problem at all.. As I couldn't find the source of the problem I reinstalled ubuntu... (Wich completely crashed my computer, due to a fatal error while trying to install the grub, it couldn't find the device.. But that's not part of the question anymore :).)

But thanks for your fast answers! :)

share|improve this question

marked as duplicate by Web-E, gertvdijk, Jorge Castro, guntbert, Eric Carvalho Aug 28 '13 at 0:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Comment above is the best method for determination of your issue. Give that a try and determine if this helps resolve the issue. –  freecode Aug 27 '13 at 17:08
    
Used boot repair: paste.ubuntu.com/6033493 This didn't solve the problem... Should I reinstall the Grub? –  Pixel Aug 27 '13 at 17:41
    
Hi @Pixel, it's unfortunate that the question marked as duplicate didn't solve your issue. If you edited your post to mention that (prior to you reinstalling Ubuntu), we could have re-opened the question and continued the investigation; but you've already reinstalled Ubuntu (and have a different issue), so this question is staying closed. You could ask another question for your new issue...but search before you post =P. Thanks! –  Alaa Aug 28 '13 at 13:14
add comment

1 Answer 1

Did you change something in the BIOS like EFI(UEFI) or LEGACY ? For more info click here

Maybe you could try installing GRUB on your sda6 partition using Boot Repair (Look into the advanced options).

Or sometimes I use Grub Customizer to correct some GRUB errors. Click here to install.

share|improve this answer
    
Well I didn't change any settings in the bios.. (At least, I'm not aware of any changes) I'll try to install GRUB on my sda6 partition :). About Grub Customizer, does it work on windows 7? –  Pixel Aug 27 '13 at 18:28
    
That didn't work, and Grub Customize seems like an ubuntu program.. :/ –  Pixel Aug 27 '13 at 18:58
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.