Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Dell XPS15 l502x dual-booting Win8 and Ubuntu 12.04.

When I try to connect my second monitor through the HDMI port, the second monitor just says there's no signal.

When I run lspci -v, I get the following:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Dell Device 04b6
Flags: bus master, fast devsel, latency 0, IRQ 50
Memory at f1400000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 4000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

When I run xrandr, I get:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192 LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm 1366x768 60.1*+ 1360x768 59.8 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)

HDMI1 disconnected (normal left inverted right x axis y axis)

DP1 disconnected (normal left inverted right x axis y axis)

I have no clue how to enable my second monitor. I do have another NVIDIA graphics card:

01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev ff) (prog-if ff) !!! Unknown header type 7f

in my laptop but I don't want to use it since the support for NVIDIA Optimus graphics cards is poor on Linux.

Can anyone suggest a fix for this? Thanks!

share|improve this question
Node was right. In xps15 l502x Ubuntu activates the Intel graphics card by default. To make use of the NVIDIA card, we have to install the bumblebee project. Link:… Quote from the blog: > Graphics >Upon installation only the integrated graphics card is active (Intel HD 3000). To enable the Nvidia card, you have to install bumblebee project (Optimus Enabler for Linux). DO NOT INSTALL THE NVIDIA PROPRIETARY DRIVER manually (If you do, you won’t be able to boot); let Bumblebee installation take care of it. – naja Aug 27 '13 at 15:52

I guess the Dell XPS15 l502x has an nvidia optimus chipset. Which has a real poor linux support at the moment. I would suggest that you would use or at least try to use the "discrete graphic only" setting in bios and install the nvidia binary driver. (be careful this impacts your battery life) Although you could try to use the latest nouveau module 1.0.9:

Please have a look at this question, may it helps you around your problem: How do I get HDMI output working on a Dell XPS 15 L502x?

share|improve this answer
Well, I know that. But I mentioned in my original post that I don't want to mess with NVIDIA graphics card. Last time I installed the NVIDIA drivers it was a nightmare. I had to remove Ubuntu and install it all over again. Doesn't my current Intel integrated graphics card support dual-screen? – naja Aug 27 '13 at 14:38
Afaik in your case the hdmi port is wired to the nvidia chip, so the intel chip can't see the port. – Node Aug 27 '13 at 14:52
Aww, this is the worst case scenario :( Thanks for your input. – naja Aug 27 '13 at 14:53
Nvidia Optimus + Linux is a world of pain. :/ – Node Aug 27 '13 at 14:56
I'll go ahead and install Bumblebee. Will see what happens... – naja Aug 27 '13 at 15:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.