Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to get this working for days now and none of the posts I've found on this site (or any other) have been able to help me fix this, so sorry if this is a repost. I'm currently trying to dual-boot Windows 7 and Ubuntu on a desktop with a Gigabyte Z87N motherboard and an NVIDIA GTX760 video card. When I try to boot Ubuntu "normally" (not in recovery mode) I'm left with a blank screen with a blinking underscore. If I try to run in recovery mode, then I get a lot of text output and then this:

[    4.429609] [drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.
[    4.429667] DRM:Fill_in_dev failed.

The system always comes to a complete halt (and again a blinking underscore at the bottom of the screen) after those two lines print. Sometimes, more lines print after that, but they always vary and dont seem to be part of the problem (they seem to just be normal messages about other drivers loading).

I followed these instructions to install my nvidia drivers.

but that didn't work (obviously). Pleeaaase help me. I know that the two error messages above have been addressed before, but I haven't found any fixes that work.

I've tried to boot with the "nomodeset" option but that doesn't seem to change anything. I've also tried to boot with "text nomodeset" and gotten the same results.

I forgot to mention that this all happens when I use the HDMI port on my graphics card. If I use the HDMI port on my motherboard, Ubuntu boots just fine. Another interesting thing I noted is that I don't see the motherboard logo or the grub menu (where I choose between Ubuntu and Windows) if I use the motherboard's HDMI. The screen just stays completely black until I see the Ubuntu login page.

Also, I have an entry in grub called "Previous Linux versions" which lets me boot into Linux 3.5.0-23-generic. I would boot into recovery mode here before and it used to work, but for some reason even that doesn't work now.

Sorry for the unorganized post...I'm not sure how to organize all this random info that I have. Please let me know if you need any more information, and thanks in advance if you can help me!

share|improve this question
    
When black screen appears press CTRL+ALT+F1 keys. It should move to command line inerface mode from where you can give login name and password to login. Reply me if you are able to login or not? –  Saurav Kumar Aug 27 '13 at 11:02
    
No this does not work. Sorry :(. There is still a blinking underscore, and that was there before. I do not see any changes when I press CTRL+ALT+F1 –  user1340033 Aug 27 '13 at 17:37
    
Then your problem is just like me. I just wanted to be confirmed. I have faced this problem before and was able to recover from it. Hope you can also recover. I am posting the solution as an answer. Just give it a try. –  Saurav Kumar Aug 28 '13 at 1:46

3 Answers 3

It was because of lightdm display manager. I installded gdm display manager and I recovered from this problem. I hope it will also work for you.

Here are the steps how to install

1. Go to following link and download gdm for Ubuntu 12.04.2 according to your OS 
architecture i386 or amd64. (chose ubuntu proposed universe out of three listed there.)

http://pkgs.org/download/gdm

2. Put the *.deb file to any drive of your system say C:\ or any other drive which was
mounted automatically when Ubuntu was starting before. (since ubuntu is not working
you have to use your Windows OS)

3. Then login in save mode. After a lot of text displayed in black screen one window
will come which list some options. First go to option "Grub Update", it will mount
your file system in read/write mode. Then chose "root" option in order to login
as root. Then go to the drive where you saved the deb file. The drive will be listed
in /media. I am assuming that you saved the file in gdm directory of C:\ which is
named as Windows, then:
   # cd /media && ls (which will list all your mounted drive)
   # cd Windows/gdm   (go to gdm directory where deb file is saved.)
   # dpkg -i *.deb    (installing gdm)
While installing gdm one window will come which will ask your to chose lightdm or gdm
from the list. Chose gdm. If this window doesn't appear then try following command.
   # dpkg-reconfigure lightdm (chose gdm)
   # reboot (reboot your system)

When you system will be reboot you will get a login screen. After login you should be able to successfully access your windows. If still you get black screen then while login chose some different options like gnome classic or gnome classic(no effects)

share|improve this answer
    
I can't log in to safe mode though. When I try, the same error message (about the agpgart module) prints. –  user1340033 Aug 28 '13 at 2:55
    
Then buddy really you have a very serious problem.. Save mode works in even a very worst situation. I don't know why for your case safe mode is not working. Try login safe mode from "Previous Linux Versions" –  Saurav Kumar Aug 28 '13 at 5:12
    
Alright, I gave up and tried to install a fresh copy of 13.04. I found out that my problem was actually caused by the Nvidia (304) drivers I installed, because when I installed them on 13.04, I received the same errors. Thankfully, I was able to boot into a previous linux version and then remove the nvidia drivers. Now I can boot into Ubuntu using the "text nomodeset" flags, but if I try to boot into the regular GUI, the screen completely shuts off. No more black cursor, the monitor just doesn't seem to be receiving any input –  user1340033 Aug 28 '13 at 6:13

The issue was simply a matter of entering my BIOS and turning off "internal graphics". I knew that the OS was defaulting to the integrated graphics because the HDMI port on the motherboard always worked correctly, but I didn't know how to tell Ubuntu to switch and use my graphics card. For Gigabyte Z87N-Wifi motherboards, simply enter the BIOS and navigate to the BIOS features section and disable internal graphics.

share|improve this answer
    
I just ran into a similar issue, where no amount of [un]installing nvidia drivers helped. It took me a while to even get to a point where I got that argpart error. Flipping "internal graphics" to disabled immediately let me boot Ubuntu and install nvidia drivers, on my Gigabyte GA-Z87X-UD3H. Thanks! –  eli Aug 4 at 2:44

Using the default Nvidia suggested drivers (319) solved my problem. I boot though through previous linux version and 3.5.0-36 Generic and activated them. Then i rebooted to 3.5.0-39 and everything was fine! Hope i helped

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.