Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I start to use ubuntu rather recently at work. Among colleagues we are used to be always available on skype. Unfortunately, on my machine, skype sometimes freezes without making me aware of that. So, I think I am online, but for the rest of the world I am off. What can I check/do?

Such behavior may show up 2/3 times a day. To restart skype, it is necessary to kill the proccess form the terminal (ctrl-q does not work).

Thanks for your patience.

share|improve this question

11 Answers 11

Tied of constantly and silently freezing Skype I've created simple wrapper for this - it's a python daemon which constantly checks it via DBUS skype API, and restart process when notifies it's frozen. Hope someone finds it useful.

https://github.com/kapliars/doctor-skype

share|improve this answer

Just a small contribution on an EXC Q&A Thread..

I'm running Ubuntu 11.10, I was having the exact same issue described (Skype silently froze, no messages could be sent/received, etc)

I don't have a /usr/lib32 folder, and under /usr/lib/ there's no libpulse.so.0.12.3, or any of the libpulse files MENTIONED HERE. I did find the files libpulsecore-1.0.so and libpulsedsp.so, I only made a

sudo chmod a-r libpulsecore-1.0.so 

and the problem dissapeared!

share|improve this answer

libpulsedsp.so also exists and needs to be modified. For me calling someone only worked after the following commands:

sudo chmod a-r libpulsecore-1.0.so 
sudo chmod a-r libpulsedsp.so
share|improve this answer

Commands for Ubuntu 11.10 64 bit

cd /urs/lib32
sudo chmod a-r libpulse.so.0.13.4 libpulse-simple.so.0.0.3 libpulsecommon-1.0.so
share|improve this answer

I had a similar problem in Ubuntu 12. I followed the instructions here to remove Pulse Audio, and seems to have worked fine since.

share|improve this answer

Skype has been labelling Beta in its Linux version. Well I don't know if it cares about us linux users coz its been beta since I don't know when. Yet it is a nice app. May be you should try completely removing the software and installing the one from cannonical partner repository or if you have done that may be try the one from skype site itself.

share|improve this answer
    
Thanks Sagarchalise. –  user13715 Apr 8 '11 at 6:58
    
I tried both versions: canonical partner repository and skype site, cleaning each time with "mark for complete removal" in Synaptic Pkg Manager. Yesterday I was notified by an updated version by "Update Manager". Now I run 2.2.0.25 --beta, of course-- and the problem still shows up. Hope Skype developers --after having recently released a decent version for Mac-- will take care of linux users... –  user13715 Apr 8 '11 at 7:05
    
yup skype did update to beta 2.2 recently. May be with completely removing the app you remove your personal Skype configuration located in $HOME/.Skype. I don't know if it will help or not but you can give it a try –  sagarchalise Apr 8 '11 at 7:13
1  
Purging an application never touches any files in the users home directories. –  Marco Mar 14 '12 at 12:48

If you're running under Ubuntu 64-bits, have a look here: https://jira.skype.com/browse/SCL-670?focusedCommentId=47773&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_47773

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Aug 10 '12 at 18:38

The suggestion at the link seems to solve me the problem too:

cd /usr/lib32
sudo chmod a-r libpulse.so.0.12.3 libpulse-simple.so.0.0.3 libpulsecommon-0.9.22.so
share|improve this answer
2  
So this will make these dynamic libraries unreadable to all users (except for root). Why does this fix the problem? –  Bogdan Dec 15 '11 at 14:34

The problem is with no doubt related with Skype when playing .wav files through pulseaudio. This issue happens mostly when chatting rather than when having an audio/video conference because Skype is configured by default to play a sound every time a message is sent/received. Since this is the most frequent event of playing .wav files, there may be at least two solutions:

  • Replace pulseaudio with ALSA (which may be controversial for a certain part of the linux community), or
  • Simply configure Skype to not play any sound when receiving/sending messages within a conversation.
share|improve this answer
1  
Why might someone not want to replace Pulseaudio with ALSA? (Right now, it would be hard for someone to judge whether or not it's a good option for them, by reading this answer. I recommend expanding the answer to include this information, or a link to somewhere where it's discussed.) –  Eliah Kagan Aug 6 '12 at 3:56

In ubuntu 12.04 LTS/32bit where I had the very same problem after some updates, I have now just libpulsecore-2.0.so and /usr/lib folder so the correct code to fix access rights would be

/usr/lib$ sudo chmod a-r libpulsecore-2.0.so

with this "fix" Skype no longer fails. Probably until libpulsecore gets updated... damn M$kype.

share|improve this answer

Can you try running Skype from the command line ie

sudo skype 

here you may see if any error messages come up. I also got around some sound issues a while ago by installing pavucontrol

sudo apt-get install pavucontrol

but since Ubuntu 11.04 was installed the sound control menu has been improved. Anyway in 10.10 pavucontrol enabled me to sort my input/mic source correctly via pulseaudio by selecting the input source. In 10.10 this action helped me have a working skype in Ubuntu

Hope that may help you . Let us know what error messages if any you get.

ps I also always deselect the allow skype to adjust my audio controls as I show below in the options section as I find skype will quite happily mess up my sound!

(BTW depending on which version of Skype you are running you may not see the message about pulseaudio below) deselect skype audio control/mess it up!

share|improve this answer
5  
Why sudo skype? That just seems like a great way to have all your local Skype config owned by root instead of your user. –  Oli Dec 15 '11 at 14:43
1  
As I wrote right at the top it enabled me to see any error messages when I opened Skype that is all –  andybleaden Dec 23 '11 at 8:20
    
@andybleaden Why wouldn't they come up just as well by running skype (without sudo) from the Terminal? –  Eliah Kagan Jun 18 '12 at 23:41
    
dunno to be frank –  andybleaden Jun 24 '12 at 20:50
    
always thought I had be superuser doh! –  andybleaden Jun 24 '12 at 20:51

protected by Community Aug 10 '12 at 19:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?