Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Somehow my dpkg stuff is messed up, and I can't install or remove anything anymore.

I am a new user to Ubuntu. I have Ubuntu 13.04 installed from a DVD on my Windows 7 laptop. I don't want to reinstall Ubuntu.

I installed i386 kernels, this program that starts with a "check", ESET antivirus, some games, Ubuntu updates, and some others.

Before, installations went fine, but after a while, every time you use the apt-get command to download and install something, it just shows many lines saying that some processes are locked.

Also, on the Ubuntu Software Center, it always gets stuck on "Applying Changes". To fix these problems, and according to what I found on the internet, I killed some processes taking up the dpkg lock. After that, I did an apt-get update, and it failed to find some servers (error 404). The program from the software center still was downloaded after the process kills, though.

After some killing of processes, the dpkg thing stopped working. On every installation (even from the Software Center), it tells you that there are MANY dependencies missing, and the install would return an error code at the end.

After this, I tried fixing dpkg, and tried installing the dependencies, but since dpkg was already screwed up, none of that could install.

Please understand that it might be the install process that's not working, not the download process.

Also, if you guys give me an answer, please understand that I cannot install any file.

By the way, I just wanted to download dpkg just to see the result.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
dpkg is already the newest version.
The following packages were automatically installed and are no longer required:
  libatk-wrapper-java libatk-wrapper-java-jni libbonobo2-0 libbonobo2-common
  libgconf2-4 libgnome2-0 libgnome2-bin libgnome2-common libgnomevfs2-0
  libgnomevfs2-common libidl-common libidl0 liborbit2 libssl0.9.8 tzdata-java
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 0 B/28.9 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
dpkg: error processing oxygen-icon-theme (--configure):
 package oxygen-icon-theme is not ready for configuration
 cannot configure (current status `half-installed')
dpkg: dependency problems prevent configuration of kde-runtime:
 kde-runtime depends on oxygen-icon-theme (>= 4:4.9.2); however:
  Package oxygen-icon-theme is not installed.

dpkg: error processing kde-runtime (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdepim-runtime:
 kdepim-runtime depends on kde-runtime; however:
  Package kde-runtime is not configured yet.

dpkg: error processing kdepim-runtime (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkgapi0:amd64:
 libkgapi0:amd64 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.

dpkg: error processing libkgapi0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkdepimdbusinterfaces4:
 libkdepimdbusinterfaces4 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.

dpkg: error proceNo apport report written because the error message indicates its a followup error from a previous failure.
                                           No apport report written because the error message indicates its a followup error from a previous failure.
                                                                     No apport report written because MaxReports is reached already
                                                   No apport report written because MaxReports is reached already
                                 No apport report written because MaxReports is reached already
               No apport report written because MaxReports is reached already
                                                                             No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                         No apport report written because MaxReports is reached already
                       No apport report written because MaxReports is reached already
     No apport report written because MaxReports is reached already
                                                                   No apport report written because MaxReports is reached already
                                                 ssing libkdepimdbusinterfaces4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkdepim4:
 libkdepim4 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.

dpkg: error processing libkdepim4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdepim-kresources:
 kdepim-kresources depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.
 kdepim-kresources depends on libkdepim4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepim4 is not configured yet.

dpkg: error processing kdepim-kresources (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcalendarsupport4:
 libcalendarsupport4 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.
 libcalendarsupport4 depends on libkdepimdbusinterfaces4 (= 4:4.10.5-0ubuntu0.1); however:
No apport report written because MaxReports is reached already
                                                                Package libkdepimdbusinterfaces4 is not configured yet.

dpkg: error processing libcalendarsupport4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libeventviews4:
 libeventviews4 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.
 libeventviews4 depends on libcalendarsupport4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libcalendarsupport4 is not configured yet.
 libeventviews4 depends on libkdepim4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepim4 is not configured yet.

dpkg: error processing libeventviews4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libincidenceeditorsng4:
 libincidenceeditorsng4 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.
 libincidenceeditorsng4 depends on libcalendarsupport4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libcalendarsupport4 is not configured yet.
 libincidenceeditorsng4 depends on libkdepim4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepim4 is not configured yet.
 libincidenceeditorsng4 depends on libkdepimdbusinterfaces4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepimdbusinterfaces4 is not configured yet.

dpkg: error processing libincidenceeditorsng4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpimcommon4:
 libpimcommon4 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.
 libpimcommon4 depends on libkdepim4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepim4 is not configured yet.

dpkg: error processing libpimcommon4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of korganizer:
 korganizer depends on kde-runtime; however:
  Package kde-runtime is not configured yet.
 korganizer depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.
 korganizer depends on libcalendarsupport4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libcalendarsupport4 is not configured yet.
 korganizer depends on libeventviews4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libeventviews4 is not configured yet.
 korganizer depends on libincidenceeditorsng4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libincidenceeditorsng4 is not configured yet.
 korganizer depends on libkdepim4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepim4 is not configured yet.
 korganizer depends on libkdepimdbusinterfaces4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libkdepimdbusinterfaces4 is not configured yet.
 korganizer depends on libpimcommon4 (= 4:4.10.5-0ubuntu0.1); however:
  Package libpimcommon4 is not configured yet.

dpkg: error processing korganizer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qapt-batch:
 qapt-batch depends on kde-runtime; however:
  Package kde-runtime is not configured yet.

dpkg: error processing qapt-batch (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kubuntu-debug-installer:
 kubuntu-debug-installer depends on kde-runtime; however:
  Package kde-runtime is not configured yet.
 kubuntu-debug-installer depends on qapt-batch; however:
  Package qapt-batch is not configured yet.

dpkg: error processing kubuntu-debug-installer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkolab0:
 libkolab0 depends on kdepim-runtime; however:
  Package kdepim-runtime is not configured yet.

dpkg: error processing libkolab0 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 oxygen-icon-theme
 kde-runtime
 kdepim-runtime
 libkgapi0:amd64
 libkdepimdbusinterfaces4
 libkdepim4
 kdepim-kresources
 libcalendarsupport4
 libeventviews4
 libincidenceeditorsng4
 libpimcommon4
 korganizer
 qapt-batch
 kubuntu-debug-installer
 libkolab0
E: Sub-process /usr/bin/dpkg returned an error code (1)

That was the code for experts to examine.

What I have tried:

  • sudo apt-get install -f && sudo apt-get autoremove gave me the same type of error.
  • sudo apt-get purge kde-runtime didn't work because "Errors were encountered while processing: oxygen-icon-theme". Everything else were removed, I guess.
share|improve this question
    
Why not starting with what was required in comments in the other question? Also, no need to use caps. –  Braiam Aug 27 '13 at 1:08
    
Sorry, because I had less than 50 reputation score. Also, I am new to this Ask Ubuntu thing. –  System Security 2009 Aug 27 '13 at 1:19
    
I don't know how come the reputation into play, but edit your post and add what was asked in comments in the other question: Could you please upload the whole /var/log/dpkg.log? Maybe you will need to use paste.ubuntu.com. –  Braiam Aug 27 '13 at 1:24
2  
I think he needs an account merger from the mods. –  Jorge Castro Aug 27 '13 at 1:41
    
Sorry there are a lot of stuff, but paste.ubuntu.com/6030958 –  System Security 2009 Aug 27 '13 at 2:05
show 1 more comment

2 Answers

I think that a bug report should be filled to some dependencies since it's not the first time that I see that someone gets their system broken due installing KDE/Kubuntu libraries and programs. I will totally remove any kde/kubuntu package with this only command:

sudo apt-get remove kde-runtime qapt-batch kubuntu-debug-installer oxygen-icon-theme kdepim-runtime libkgapi0 libkdepimdbusinterfaces4 libkdepim4 libcalendarsupport4 libkdepimdbusinterfaces4 libeventviews4 libeventviews4 libincidenceeditorsng4 libkolab0 libkgapi0 libkdepimdbusinterfaces4 libkdepim4 kdepim-kresources libcalendarsupport4 libeventviews4 libincidenceeditorsng4 libpimcommon4 korganizer qapt-batch kubuntu-debug-installer libkolab0
sudo apt-get autoremove
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

If any of this fails, stop right there, edit your question and include the command that failed with the output.

share|improve this answer
add comment
up vote 0 down vote accepted

I accidentally tried to install the Platinum Arts Sandbox Gamemaker app. That installation will always get stuck on the "Applying Changes" part. I ended up with this because I tried to kill the process of installing the game. I think that it is not compatible with my OS version (13.04).

So long story short, reinstall your OS. Hopefully, there's not much on there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.