Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first installation of Ubuntu, but I've been running it live on a DVD and flash drive for months. Today I installed Ubuntu 13.04 onto a 3-year old Lenovo G550 laptop, and it has a proprietary Broadcom wireless driver.

When I booted Ubuntu as a live system from the DVD, telling Ubuntu to use the proprietary driver in the settings menu was straightforward, and I was able to connect to my home wifi. However, after installation, I attempted to do the same process, but after I hit "apply changes" after selecting "use broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (propretary)", I was met by a pop-up telling me to authenticate. I entered my password, and hit enter. The window dims, a bar indicates that the change is working, but then it changes again to "do not use driver."

For some reason, the driver just won't install. It worked when I was running Ubuntu live, but after installation it won't work. What do I do? My laptop is compromised if I can't use the wireless (because Windows 7 crashed on the computer).
Any help would be greatly appreciated.

share|improve this question
    
Sometimes a kick fixes it (I mean reboot the PC). –  Braiam Aug 26 '13 at 23:33
    
I also faced similar problems.... None of the above steps worked for me.... Pls help me out.... Thanks –  Raj Apr 15 at 3:02
    
Please reply if the Saurav Kumar's solution works. –  Danatela Apr 15 at 3:36
add comment

2 Answers

It seems that there is some problem occurred when you installed Wireless Broadcom 802.11 driver. You can give a try to followings:

  1. Open a terminal and execute following commands:

    $ sudo (jockey-gtk &)
    $ sudo update-grub
    $ sudo update-initramfs -u
    

    jockey-gtk will automatically searches all available drivers and try to fix it. Then restart your system.

  2. Try to reconfigure installed Broadcom Wireless Driver

    $ sudo dpkg-reconfigure bcmwl-kernel-source
    

    if it still doesn't work then re-install it by completely removing it:

    $ sudo apt-get autoremove bcmwl-kernel-source
    $ sudo apt-get --purge remove bcmwl-kernel-source
    $ sudo apt-get install bcmwl-kernel-source
    
  3. Try to update your system, sometimes updating fixes a lot of issues. Update your system after removing any broken packages, residual unused packages, execute these commands:

    $ sudo apt-get autoremove
    $ sudo apt-get autoclean
    $ sudo apt-get install
    $ sudo apt-get update
    $ sudo apt-get upgrade
    

I hope any of these steps work for you. Reply if something goes wrong..

share|improve this answer
    
sorry --- navigating the site yesterday with a phone I inadvertently downvoted it. Had to do a null edit to remove the downvote. –  Rmano 2 days ago
add comment

Uninstall the bcmwl-kernel-source package by issuing the following command on a terminal:

sudo apt-get remove bcmwl-kernel-source

make sure that the firmware-b43-installer and the b43-fwcutter packages are installed (of course you will need internet by others means):

sudo apt-get install firmware-b43-installer b43-fwcutter

type into terminal:

cat /etc/modprobe.d/* | egrep 'bcm'

(you may want to copy this) and see if the term 'blacklist bcm43xx' is there

if it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

put a # in front of the line: blacklist bcm43xx

reboot

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.