Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I dual boot windows and ubuntu. I had a nice setup which I've been using for a couple weeks now. I decided to put Steam on the Ubuntu side and it said, hey, you can get newer video drivers. I was on 304 I think, and the OS recommended 311.

I downloaded and installed the new drivers. It says to reset, so I log out, but then all I have is a blinking cursor instead of the login screen (where I would have reset from.) I waited 30 minutes and nothing happened so I reset via holding the power button.

Now when I boot I don't even see the Asus splash screen. Also, if I wait until I know grub is loaded and scroll down to windows (by memory, video is dead) I know it starts because I hear that dumb chimey sound, but still no video.

I'm not that great at computers, and given I have no video to work with, I can only give information from memory. I've tried all my dvi and hdmi ports to no avail. I have a 660ti.

I know its not much to go on, I'm just casting a net here.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

My sympathies go out to you because I have been using those exact drivers without any trouble at all. Well, here is something that may solve the issue:

First, plug in your screen to the port that originally was plugged in to. If that doesn't work, try booting at least twice with each video port until it does work. BIOSes tend to be buggy.

Once you can at least boot and see a splash screen, boot into Ubuntu Recovery Menu at the Grub screen. Scroll down to Enable Networking and follow the process. Upon return to the main Recovery Mode menu, select the option to get to a Root Shell Prompt. Enter in this command and press Enter:

apt-get install --reinstall nvidia-304

Then go back to the menu with exit, and then reboot. The issue should be solved.

share|improve this answer
    
Weird! I tried an old Dell monitor and I got video. Must have to do with the resolution? This is a 1024x768 monitor. Regardless I will use your instructions for a rollback. Thank you. –  Themanwhowas Aug 26 '13 at 18:48
    
Well it worked. You're proof the internet is not a bunch of servers and wires, its the people that use it! Thanks. –  Themanwhowas Aug 26 '13 at 18:57
    
Cool! Since it worked, would you mark this as the answer just in case someone else has the same problem and wants to fix it? –  searchfgold6789 Aug 26 '13 at 19:34
    
Maybe it did have something to do with the resolution: perhaps 1024x768 being the only resolution available due to lack of support from the malfunctioning driver was not supported by the monitor. Hmm. –  searchfgold6789 Aug 26 '13 at 19:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.