Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently bought a JBL Charge bluetooth/portable speaker. Now I am very very happy with this device, it is awesome, I do have a problem with it too.

At first pairing all goes well, I go through the pairing sequence and behold: It works! But then the next time you turn it on,the blue led starts blinking, it beeps and then the blue led comes on full time, which should mean it is connected, but it's not. It does not show up in sound settings as an option.

The only way I can get it to work with Ubuntu is to: a) remove the JBL Charge in bluetooth settings completely. b) go through the pairing sequence...

Anybody got any tips on settings and files that control this behaviour? It would be nice to have it working every time I turn it on.

Thanks!

share|improve this question
1  
try this solution: askubuntu.com/questions/68939/… to bug #931860. Your issue smells of SSP issue. Versions? –  Takkat Aug 26 '13 at 12:18
    
I tried that, didn't work for my adapter...(Can't set Simple Pairing mode on hci0: Input/output error (5)) I am on 12.04 (3.2.0-52-generic-pae) and fully updated. There is no way I can use some settings to correct this? Preferably to be run at boot time. –  Ashrael Aug 26 '13 at 15:05
    
I bet there is but I don't know of it. It may also be a setting to be made on the JBL side. Did you check if your Ubuntu BT is "visible" (should be ON by default)? My BT device always loses pairing after it was paired to another PC including a VM (using the same dongle) - this makes me believe it may be something on the device's side. –  Takkat Aug 26 '13 at 15:50
    
well, I do not have that problem when pairing to my phone, so I think it is a linux/ubuntu issue. –  Ashrael Aug 26 '13 at 17:59
    
It works! I tried to connect and it didn't work a couple of times, then all of a sudden I get asked for a pincode, I type 0000 and now it connects every time... Why this pincode was asked of me all of a sudden as opposed to all other previous times I don't know. But it re-affirms my belief that it is/was a linux/ubuntu thing, but I still could be wrong. –  Ashrael Sep 1 '13 at 12:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.