Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 4 monitors I'm trying to set up in Unity with 2 GPU's (2x AMD HD7970's). Originally I had 2 monitors on each card and tried to set it up that way, but I kept getting the White Screen of Death and could not resolve the problem.

I then decided to put all 4 monitors on a single card (1 HDMI, 2 DVI, 1 Mini Display Port) and Crossfire with the second card.

Upon a fresh install, the open source drivers worked and all four monitors worked correctly. The problem is that the open source drivers caused Unity to run excruciatingly slow, making it very difficult to work with. When I say slow, I mean the cursor was slow, windows would take several seconds to slowly fade in, responsiveness was slow, etc....

I decided to check out the proprietary drivers, because I had read that the open source drivers don't really handle 3D Acceleration correctly. I installed the AMD 13.04 drivers from the website, and got 2 monitors to appear, but I cannot get the other two to activate.

Just to be clear, all four monitors are recognized by the drivers, but when I try to activate them in catalyst (using sudo amdcccle) the changes are ignored and only 2 monitors are used. When I try xinerama all 4 screens will 'turn on' and be recognized, but Unity turns black and no windows appear (the only thing I can see is the cursor).

When I try to use RandR it complains about requested size and then a maximum/minimum virtual size (something similar to the following:

The selected configuration for displays could not be applied required virtual size does not >fit available size: requested=(2646, 1024), minimum=(320, 200), maximum=(1366,1366).

As a result I've tried going into xorg.conf and adjusting the virtual size as recommended here: Multi screen problems "virtual size does not fit available size". I've also tried the amdcccle solution provided in that article.

If I try to activate the other 2 windows and arrange them in RandR it says it's unable to make the requested change (I believe a error with CTRC 148).

At this point I'm not sure what to try to make all my monitors work with Ubuntu while allowing 3D Acceleration for reasonable performance. How can I fix this, Is it possible? Is this issue with all GNOME desktops, or just Unity? I've been debating switching to Kubuntu just because this problem is kind of debilitating and I hear KDE runs better with multiple monitors, but I'd really prefer to stay in Unity if possible.

Note: I will try to post my xorg.conf once I log into Ubuntu, I'm writing this from my Windows bootup

share|improve this question
    
I have a similar problem, but i think it's not the driver but the card itself. I tried setting up 3 monitors with my 5700HD on Windows7 (HDMI, DVI, VGA). Result was the same. –  zulu34sx Sep 6 '13 at 8:43
add comment

1 Answer

the new beta 13.8 drivers from AMD actually took care of the issue for me, and supported all monitors out of the box. Just make sure when you access amdcccle that you use gksu instead of sudo. thus far everything has been working great now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.