Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can anyone help me with this?

During dist upgrade something happened, broken packages occured and unmet dependecies are shown, so after that in the terminal asked me to type in this command "apt-get -f install" and so I did try that and this is what I got:

    sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    libjack-jackd2-0 libjack-jackd2-0:i386
    Suggested packages:
    jackd2 jackd2:i386
    The following NEW packages will be installed:
    libjack-jackd2-0 libjack-jackd2-0:i386
    0 upgraded, 2 newly installed, 0 to remove and 6 not upgraded.
    Need to get 0 B/398 kB of archives.
    After this operation, 996 kB of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Selecting previously unselected package libjack-jackd2-0.
    (Reading database ... 248346 files and directories currently installed.)
    Unpacking libjack-jackd2-0 (from .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_amd64.deb) ...
    Selecting previously unselected package libjack-jackd2-0:i386.
    Unpacking libjack-jackd2-0:i386 (from .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb (--unpack):
    './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb

    E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried the following:

    sudo dpkg --configure -a <--- didn't work,
    sudo apt-get -f install <--- didn't work,
    sudo gedit /var/lib/dpkg/status <---- I tried removing the broken package, still the same after using "sudo fuser -vki /var/lib/dpkg/lock".

hmmmm.. help pls.. I'm stuck, and if this is a duplicate post regarding libjackd2 can anyone redirect me to another post which was solved?..

share|improve this question
    
is there any way that I can just bypass or remove lmms forcely without triggering this package error?.. –  insignia92 Aug 27 '13 at 0:18
    
did you add some PPA or other repositories like KXStudio ? –  ttoine Aug 27 '13 at 20:52

3 Answers 3

try first to clean the package cache (sudo apt-get clean) and install again.

Possible you should first try to uninstall the two packages:

sudo apt-get remove libjack-jackd2-0 libjack-jackd2-0:i386

and try to install again.

share|improve this answer
    
I did that already and what I get is this pastebin.com/aRMJUkdG –  insignia92 Aug 26 '13 at 11:34
    
pastebin.com/1w7pD2ZE updated with the /var/log/dkpg.log –  insignia92 Aug 26 '13 at 11:40
    
I don't know but in this post [here]askubuntu.com/questions/300256/… , it fixed it, which is I just renamed the package.. how is that a solution?.. O.o –  insignia92 Aug 27 '13 at 0:27

You shouldn't install the same package for both architecture at the same time, either install libjack-jackd2-0 or libjack-jackd2-0:i386. I recommend you to no install the i386 one since your system is 64bit. A simple:

sudo apt-get install libjack-jackd2-0

Should do the work.

share|improve this answer
    
I don't know but in this post [here]askubuntu.com/questions/300256/… , it fixed it, which is I just renamed the package.. how is that a solution?.. O.o ^---- this was the solution. –  insignia92 Sep 4 '13 at 10:12
    
@insignia92 that question has no answer? how could ever solve your problem? –  Braiam Sep 4 '13 at 11:27
    
You don't get it, it was solved by himself, he shared what he did and I just followed it.. and first of all the things you wanted me to do was already done by me before asking for help which didn't really work, because it would trigger a package dependency error which you might see it on the pastebin results I posted on the help above. it has an answer though, all you need to do is change the folder name to something new, because it was looking at it as a duplicate which didn't match its content, that is why I changed it and presto it worked doing : sudo apt-get install libjack-* –  insignia92 Sep 5 '13 at 23:16
    
@insignia92 he's asking why it worked (at the very end he ask "why?") and I'm telling you why it shouldn't. He's messing with his packages installing 32-bits packages in a 64-bits system, who knows what problem may arise later consequence of this. I don't know what package you installed that provoked this (nor his), and is normally the addition of random PPA, ignoring the fact that they may run into problems later or the use of skype. –  Braiam Sep 5 '13 at 23:46
    
@insignia92 You don't provide enough details about the events a priori, nor I'm expecting them (most of users don't know what they installed the last week). But let me tell you, if I found my self in the same bind that you are, my first action will never be moving files in my filesystem manually, for that is apt (Advance Package Tool). –  Braiam Sep 5 '13 at 23:47
up vote 0 down vote accepted

What solved the problem was this:

I just changed the package-name from libjack-jackd2-0 to libjack-jackd2-0.old, then I did the

  sudo apt-get install libjack-jackd2-0 libjack-jackd2-0:i386

It work for me, was because of this(This was the hint) which made me try following what he did:

'./usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system

what I did was I looked at the /usr/shar/doc/ to look for the libjack-jackd2-0 folder found it and appended in its name ".old" so that it won't find it again when doing the

  sudo apt-get -f install libjack-jackd2-0 libjack-jackd2-0:i386

after changing the name, I tried doing the apt-get -f install it worked and it went smoothly as it should be and now everything's fine, I can install now using sudo apt-get without errors. I don't have to worry for later consequences because after that completed upgrade I removed the software or application that was using those packages via apt-get remove which was lmms(Linux MultiMedia Studio) and did some sudo apt-get autoremove if in-case there were packages left useless and never did I try re-installing it again.

Just got lucky I think. but I definitely don't recommend on doing this on every package dependency error because not all show the same errors;

Definitely reading and analyzing the error helped a lot. because some answered disabling the package on the package tree, some say remove the package and install again but got lucky that it was just a build file error.

I hope this helps..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.