Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using the Ubuntu Precise (12.04 LTS).

I have some errors in configuration after Skype (downloaded from the site of Skype) installation.

At this moment I can't install nothing, even using Ubuntu Software Center.

Maybe the source of these errors was that I followed the procedure described in How to install CodeLite on Ubuntu? to install the Codelite.

I removed the Codelite and its repository ('deb http://repos.codelite.org/ubuntu/ precise universe').

Then I reinstalled Skype.

But now : the Skype is working, the operating system has configuration errors, and I can't install nothing.

Below I am putting the suggestions of solution ("third" block of code):

$ dpkg -S /usr/share/lintian/overrides/libtiff4
libtiff4: /usr/share/lintian/overrides/libtiff4

$ export LANG=C

$ sudo dpkg --purge libtiff4
dpkg: dependency problems prevent removal of libtiff4:
 libcupsimage2 depends on libtiff4.
 libpoppler19 depends on libtiff4.
 libtiff4-dev depends on libtiff4 (= 3.9.5-2ubuntu1.5).
 libevince3-3 depends on libtiff4.
 libdevil1c2 depends on libtiff4; however:
  Package libtiff4 is to be removed.
 libgs9 depends on libtiff4.
 libopencv-highgui2.3 depends on libtiff4.
 libtiff-tools depends on libtiff4.
 gimp-plugin-registry depends on libtiff4; however:
  Package libtiff4 is to be removed.
 libcupsfilters1 depends on libtiff4.
 libtiffxx0c2 depends on libtiff4.
 libgdk-pixbuf2.0-0 depends on libtiff4.
 libqtgui4 depends on libtiff4.
 libspandsp2 depends on libtiff4.
 libwxgtk2.8-0 depends on libtiff4; however:
  Package libtiff4 is to be removed.
 libsane depends on libtiff4.
 libmagickcore4 depends on libtiff4.
 gimp depends on libtiff4.
dpkg: error processing libtiff4 (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 libtiff4

$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libqtgui4:i386:
 libqtgui4:i386 depends on libtiff4; however:
  Package libtiff4:i386 is not installed.
dpkg: error processing libqtgui4:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:i386:
 libqt4-declarative:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-declarative:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqtwebkit4:i386:
 libqtwebkit4:i386 depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqtwebkit4:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of skype:i386:
 skype:i386 depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:i386 is not configured yet.
 skype:i386 depends on libqtwebkit4 (>= 2.2~2011week36); however:
  Package libqtwebkit4:i386 is not configured yet.
dpkg: error processing skype:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqtgui4:i386
 libqt4-declarative:i386
 libqtwebkit4:i386
 skype:i386

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-44-generic libunistring0 libwxsqlite3-2.8-0
  linux-headers-3.2.0-44 po-debconf g++ intltool-debian gettext
  nvidia-settings-updates qt4-qmake latex-cjk-xcjk
  linux-headers-3.5.0-23-generic linux-headers-3.5.0-23 libgettextpo0
  wx-common texlive-lang-ukenglish libmail-sendmail-perl
  libsys-hostname-long-perl
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libtiff4:i386
The following NEW packages will be installed:
  libtiff4:i386
0 upgraded, 1 newly installed, 0 to remove and 24 not upgraded.
4 not fully installed or removed.
Need to get 0 B/143 kB of archives.
After this operation, 501 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 417982 files and directories currently installed.)
Unpacking libtiff4:i386 (from .../libtiff4_3.9.5-2ubuntu1.5_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb     (--unpack):
 './usr/share/lintian/overrides/libtiff4' is different from the same file on the     system
Errors were encountered while processing:
 /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


$ sudo apt-get --reinstall install libtiff4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
$ 

$ sudo apt-get update

$ sudo apt-get -f install

(Reading database ... 417982 files and directories currently installed.)
Unpacking libtiff4:i386 (from .../libtiff4_3.9.5-2ubuntu1.5_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb     (--unpack):
 './usr/share/lintian/overrides/libtiff4' is different from the same file on the     system
Errors were encountered while processing:
 /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not installed
E: Unmet dependencies. Try using -f.
$ 


$ sudo apt-get -f install libqtgui4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqtgui4 is already the newest version.
libqtgui4 set to manually installed.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

$ sudo apt-get  install libtiff4:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-44-generic libunistring0 libwxsqlite3-2.8-0
  linux-headers-3.2.0-44 po-debconf g++ intltool-debian gettext
  nvidia-settings-updates qt4-qmake latex-cjk-xcjk
  linux-headers-3.5.0-23-generic linux-headers-3.5.0-23 libgettextpo0
  wx-common texlive-lang-ukenglish libmail-sendmail-perl
  libsys-hostname-long-perl
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  libtiff4:i386
0 upgraded, 1 newly installed, 0 to remove and 28 not upgraded.
4 not fully installed or removed.
Need to get 0 B/143 kB of archives.
After this operation, 501 kB of additional disk space will be used.
(Reading database ... 417982 files and directories currently installed.)
Unpacking libtiff4:i386 (from .../libtiff4_3.9.5-2ubuntu1.5_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb     (--unpack):
 './usr/share/lintian/overrides/libtiff4' is different from the same file on the     system
Errors were encountered while processing:
 /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt-get autoclean
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Del codelite 5.2-1.precise [21.3 MB]
Del sdformat 1.4.5-1~precise [323 kB]
Del gazebo 1.9.0-1~precise [37.2 MB]
Del wxcrafter 1.2-1.precise [2314 kB]
Del gazebo 1.9.1-1~precise [37.2 MB]

$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not installed
E: Unmet dependencies. Try using -f.

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-44-generic libunistring0 libwxsqlite3-2.8-0
  linux-headers-3.2.0-44 po-debconf g++ intltool-debian gettext
  nvidia-settings-updates qt4-qmake latex-cjk-xcjk
  linux-headers-3.5.0-23-generic linux-headers-3.5.0-23 libgettextpo0
  wx-common texlive-lang-ukenglish libmail-sendmail-perl
  libsys-hostname-long-perl
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libtiff4:i386
The following NEW packages will be installed:
  libtiff4:i386
0 upgraded, 1 newly installed, 0 to remove and 28 not upgraded.
4 not fully installed or removed.
Need to get 0 B/143 kB of archives.
After this operation, 501 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 417982 files and directories currently installed.)
Unpacking libtiff4:i386 (from .../libtiff4_3.9.5-2ubuntu1.5_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb     (--unpack):
 './usr/share/lintian/overrides/libtiff4' is different from the same file on the system
Errors were encountered while processing:
 /var/cache/apt/archives/libtiff4_3.9.5-2ubuntu1.5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt-get -u dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not installed
E: Unmet dependencies. Try using -f.

$ sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not installed
E: Unmet dependencies. Try using -f.
$ 

The trials until now:

$ sudo apt-get update
$ sudo apt-get -f install
$ sudo dpkg --configure -a
$ sudo dpkg --purge libtiff4
$ sudo apt-get --reinstall install libtiff4
$ sudo apt-get  install libtiff4:i386
$ sudo apt-get autoclean
$ sudo apt-get autoremove
$ sudo apt-get -f install

Trying to get a solution at: How do I resolve unmet dependencies?

$ sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqtgui4:i386 : Depends: libtiff4:i386 but it is not installed
E: Unmet dependencies. Try using -f.

$ sudo apt-get remove libqtgui4:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libqt4-declarative:i386 : Depends: libqtgui4:i386 (= 4:4.8.1-0ubuntu4.4) but it is not going to be installed
 libqtwebkit4:i386 : Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
 skype:i386 : Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
              Recommends: sni-qt:i386 but it is not going to be installed
              Recommends: libasound2-plugins:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
    
Could you remove libtiff4 with dpkg --purge libtiff4 and then again dpkg --configure -a, apt-get install -f? Please do an export LANG=C first, so that the output is in English, in case you want to post it here. –  JoBo Aug 27 '13 at 12:08
    
You have a serious dependency problem. Run the commands one by one, if some fail just update the question, don't use the laters. Install libqtgui4 with sudo apt-get -f install libqtgui4. –  Braiam Aug 28 '13 at 0:24
    
I put there in the third block, the command didnt worked. –  Juracy Emanuel Aug 28 '13 at 0:46
    
Reading: ia32-libs-multiarch but it is not installable bugs.launchpad.net/ubuntu/+s...s/+bug/1016294 Unmet Dependencies- I am Totally Lost ubuntuforums.org/archive/inde...t-2078792.html –  Juracy Emanuel Aug 30 '13 at 14:47

2 Answers 2

You should reinstall libtiff4 first so you can remove it:

sudo apt-get --reinstall install libtiff4
sudo apt-get update
sudo apt-get -f install
sudo apt-get upgrade
share|improve this answer
    
Braiam, unfortunatelly didnt worked. I put the results in the third block of code of my ask. –  Juracy Emanuel Aug 28 '13 at 0:14

Described at:

http://ubuntuforums.org/showthread.php?t=2171281&page=3

A possible answer:

My interpretation (I readed some comments in the posts about this) of this trouble is that there is a "bug" that makes inviable to run software like Skype:i386 (32-bit programs, because in some moment will appear the unmet dependencies) on the Ubuntu 64-bit. I am sorry about that, because I have a Ubuntu 64-bit and I need to use the Skype.

The indirect solution that solved, for me, the trouble with unmet dependencies was in the way of squakie (http://ubuntuforums.org/showthread.php?t=2171281) suggestion:

Using: sudo apt-get build-dep libqtgui4:i386

Resulted in : Removing skype:i386 ... Removing libqtwebkit4:i386 ... Removing libqt4-declarative:i386 ... Removing libqtgui4:i386 ..

And the using: sudo apt-get build-dep libtiff4:i386

Removed: libqt4-declarative:i386 libqtgui4:i386

So the trouble of unmet dependencies related with :i386 libraries was solved.

But, unfortunatelly, I havent the Skype installed.

Juracy

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.