Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a Samsung 900X Ultra-book with Windows 8 Pro preinstalled and wanted to install Ubuntu 13.04 alongside (as dual-boot) from a DVD which came with a Linux-Ubuntu special edition of a magazine. But i cannot make my ultra-book boot from an external dvd-drive. I already looked into the UEFI-Firmware Settings. But as I am a total newbie, I am not sure what I have got to change in order to be able to boot from a different source than my ssd. Can somebody help me?

share|improve this question
    
How to you have boot order set in the BIOS? –  Mitch Aug 26 '13 at 5:05

1 Answer 1

May be this can help you. Just try once..

You have to follow these very simple steps..

Connect your external HDD and start your system. This time boot from your Ubuntu LiveCD/DVD inserted and select 'Try Ubuntu' (not 'Install Ubuntu'). When system starts open ternal (CTRL+ALT+T) and execute following commands:

Installing boot-repair ( a good s/w to fix grub ):

    $ sudo add-apt-repository ppa:yannubuntu/boot-repair
    $ sudo apt-get update
    $ sudo apt-get install boot-repair
    Run boot-repair from your system or type: (boot-repair &) in terminal

When started select Option 'Recommended Repair' from out of two options:

'Recommended Repair' & 'Advanced Options'.

Follow very easy onscreen instruction, it will build/fix your grub..

Restarting your system may list all the Operating Systems installed in your all HDD.

Be sure that you have properly shut down your Windows 8 OS, before starting these steps.

share|improve this answer
    
The OP can't boot from the external DVD, he/she can't do the steps that you listed, since Ubuntu is not installed yet. –  Mitch Aug 26 '13 at 4:59
    
ouch! My mistake. He mentioned a sentence above: " But i cannot make my ultra-book boot from ** an external dvd-drive. **" I read it as external hdd-drive.. –  Saurav Kumar Aug 26 '13 at 5:30
    
I am a she. Thanks for trying to help. Somehow I managed to install ubuntu as dualboot system. I had to disable fast and secure boot in the uefi firmware options. But i must′ve made a mistake. To access windows 8 now, I have to return everytime to the uefi firmware options and re-enable secure boot. Despite that Windows 8 is listed: -Ubuntu -Windows 8 (loader) (on /dev /sda2) -Windows Recovery Environment (loader) (on /dev /sda6) -System Setup. If I try Windows 8 (loader) (on /dev /sda2) the following error notes appear: error: can′t find command ′drivemap′. error: invalid EFI file path. –  Annina Aug 26 '13 at 12:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.