Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since the last kernel update for Ubuntu 13.04, the folder /sys/kernel/debug/vgaswitcheroo/switch is gone on my Laptop, an Acer Aspire 3820TG.

Checking the output of grep -i /boot/config-* tells me that my kernel supports switcheroo however, the file is gone (and yes, I checked that as root).

Can anybody please give me a hint? I almost checked the whole internet for an appropriate answer but nobody seems to have the same problem.

share|improve this question

1 Answer 1

I had the same problem, and I also looked everywhere, tried everything.

Finally I got it working installing the next packages:

i965-va-driver intel-gpu-tools xserver-xorg-video-intel-dbg xserver-xorg-video-radeon-dbg xserver-xorg-video-r128-dbg xserver-xorg-video-ati-dbg

note: using kernel 3.8.0-31-generic

I am not sure what did the trick but it worked, now I can see the /sys/kernel/debug/vgaswitcheroo/switch.

Good luck, Regards

Giri

share|improve this answer
    
I installed that packages but it didn't help :( Im really frustraded with that, there is no solution in sight. Well, I hope some future kernel will fix the problem. –  Eddy Oct 11 '13 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.