Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There's a picture of what comes up.

1

This comes up every time I try to extract videorange. I've tried .mp4, .MPG, and .flv files and it says the same thing each time. I looked it up on youtube, and .mp4 worked for someone else. I'm pretty sure that the problem must be beyond that but I don't know what it is.

share|improve this question

closed as off-topic by RolandiXor Sep 2 '13 at 17:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – RolandiXor
If this question can be reworded to fit the rules in the help center, please edit the question.

    
10.04 Desktop support is no longer on topic here, as 10.04 Desktop is past EOL. –  Thomas W. Sep 2 '13 at 20:35

1 Answer 1

up vote 2 down vote accepted

From what I understand about packaging and digging through the source and configure options, this functionality does not work because the program was packaged as a Debian Free Software Guidelines (DFSG) compatible package. You know, the reason why you need to install the (k)ubuntu-restricted-extras meta packages.

The following lines in the file debian/rules in the source package seem to be the culprit here:

DEB_CONFIGURE_EXTRA_FLAGS := \
        --disable-audio-support \
        --disable-libxvidcore \
        --disable-libavformat \
        --disable-libmpeg3

Which literally disables the complete functionality you are looking for. I checked with a WEBM/VP8 and Theora video file without audio that I converted by myself with ffmpeg - doesn't work.

I could only find the dfsg packages on lauchpad and searching on the Internet for "ubuntu gimp-gap" packages only brought up the same results.

Your only choice at the moment is to repackage the package yourself (see the packaging guide). Throw out all the lines mentioned above and probably modify the first line of extern_libs/configure_options_ffmpeg.txt to look like this:

--enable-shared --enable-static --disable-mmx --enable-nonfree --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libx264 --enable-libxvid

Besides: Please update to the current LTS (12.04).


Bugs reported:

Extract video range feature is broken in Gimp-GAP

Mplayer based extraction does not work with Mplayer2 or mpv

share|improve this answer
    
I cannot update now, as my computer doesn't exactly support it (I'll cross that hurdle when I have too). If I were to repackage it, how difficult would it be on a scale of 1 to 10? And how would I go about repackaging it? –  Brooke Aug 25 '13 at 11:08
    
I'm just trying to get into this packaging stuff again. Years ago I would have rated the guide as an 8, but it looks like it got easier. –  LiveWireBT Aug 25 '13 at 11:21
    
Crap, I know nothing about this, but its a start. Thank you! –  Brooke Aug 25 '13 at 11:38
    
Currently setting up pbuilder... may be you get a working package in a day or earlier. Can't make any promises though. –  LiveWireBT Aug 25 '13 at 11:53
    
Sorry I have to give up on this, it's more than just changing some config flags and rebuilding. –  LiveWireBT Aug 25 '13 at 13:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.