Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot run sudo update-manager. I dont know whats wrong. Do you know?

(precise)acer@localhost:~$ sudo update-manager
[sudo] password for acer: 

(process:5761): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
WARNING:root:estimate_kernel_size_in_boot() returned '0'?
Traceback (most recent call last):
File "/usr/bin/update-manager", line 64, in <module>
help=_("Directory that contains the data files").decode(enc))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 17: ordinal not           in range(128)
(precise)acer@localhost:~$ 


(precise)acer@localhost:~$ sudo dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "sv_SV:en",
LC_ALL = (unset),
LC_MESSAGES = "sv_SV.UTF-8",
LANG = "sv_SV.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
en_AG.UTF-8... up-to-date
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NG.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZM.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
sv_FI.UTF-8... up-to-date
sv_SE.UTF-8... up-to-date
Generation complete.
(precise)acer@localhost:~$ 

I use swedish language, but not swedish keyboard layout beacuse i dont know how to install that.

share|improve this question
add comment

2 Answers

open your terminal and type as

sudo apt-get install --reinstall update-manager

then try again.

share|improve this answer
    
accept the answer if its helped you. –  raaz Aug 25 '13 at 15:14
add comment

One problem is that your locale is incorrectly set; there is no "sv_SV.UTF-8" locale.

Please use System Settings -> Language Support to select Swedish for both the language and the regional formats. Then, after you have logged out and re-logged in, try to run update-manager again.

Go to System Settings -> Keyboard Layout to set a keyboard layout that matches your physical keyboard.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.