Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a password change. It wasn't memorable enough. I reset my password using a series of commands from the root shell in recovery mode:

# mount -rw -o remount /
# passwd {username}
Enter new password:
Successfully changed.
# exit

restart computer. I then entered my password and it acted like it was going to log on but brought me back to the login page.

I used Ctrl + Alt + F1 and logged in successfully. dir and ls yield two files: README.txt, and Something along the lines of desktop-private-files-and-folders.dir. I cannot cd to any directory.

I tried to use the live cd but in the test profile when I try to access the information on my mounted hard drive it tells me that I do not have permission to access. Neither can I copy that information.

I have tried to be as thorough and detailed as possible without adding any fluff.

share|improve this question

1 Answer 1

It appears that you set up an encrypted home directory for your user account.

You have probably broken the decryption of the ecryptfs mount passphrase and will need to use ecryptfs-recover-private to recover it - see the instructions in this answer to a related question Encrypted Home... Forgotten Password, but no Passphrase

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.