Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to get my touchpad on a toshiba satellite laptop working. It used to work but for some reason it stopped at some point. I have no idea how long it hasn't been working because I used a mouse all summer but a fresh install is really the last resort here. I've spent a few hours searching for an answer and I'm stumped... and ya I already tried fn + f9.

Here's what I tried that might be helpful: xinput list displays this:

     Virtual core pointer                       id=2    [master pointer  (3)]
⎜     ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜     ↳ Logitech Unifying Device. Wireless PID:101d id=13   [slave  pointer  (2)]
⎜     ↳ SynPS/2 Synaptics TouchPad                  id=11   [slave  pointer  (2)]
⎣     Virtual core keyboard                     id=3    [master keyboard (2)]
  ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
  ↳ Power Button                                id=6    [slave  keyboard (3)]
  ↳ Video Bus                                   id=7    [slave  keyboard (3)]
  ↳ Power Button                                id=8    [slave  keyboard (3)]
  ↳ USB 2.0 Camera                              id=9    [slave  keyboard (3)]
  ↳ AT Translated Set 2 keyboard                id=10   [slave  keyboard (3)]
  ↳ Toshiba input device                        id=12   [slave  keyboard (3)]

So it at least recognizes the touchpad. Then I did xinput list-props 11 and that displayed this:

Device 'SynPS/2 Synaptics TouchPad':
Device Enabled (133):   1
Coordinate Transformation Matrix (135): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (260): 0
Device Accel Constant Deceleration (261):   1.000000
Device Accel Adaptive Deceleration (262):   1.000000
Device Accel Velocity Scaling (263):    10.000000
Device Product ID (250):    2, 7
Device Node (251):  "/dev/input/event10"
Evdev Axis Inversion (264): 0, 0
Evdev Axis Calibration (265):   <no items>
Evdev Axes Swap (266):  0
Axis Labels (267):  "Abs MT Position X" (258), "Abs MT Position Y" (259), "Abs Pressure" (256), "Abs Tool Width" (257), "None" (0), "None" (0)
Button Labels (268):    "Button Left" (136), "Button Unknown" (253), "Button Right" (138), "Button Wheel Up" (139), "Button Wheel Down" (140)
Evdev Middle Button Emulation (269):    0
Evdev Middle Button Timeout (270):  50
Evdev Third Button Emulation (271): 0
Evdev Third Button Emulation Timeout (272): 1000
Evdev Third Button Emulation Button (273):  3
Evdev Third Button Emulation Threshold (274):   20
Evdev Wheel Emulation (275):    0
Evdev Wheel Emulation Axes (276):   0, 0, 4, 5
Evdev Wheel Emulation Inertia (277):    10
Evdev Wheel Emulation Timeout (278):    200
Evdev Wheel Emulation Button (279): 4
Evdev Drag Lock Buttons (280):  0

If I'm reading that correctly it says the touchpad is enabled and it still doesn't work. The mouse doesn't move, it doesn't click and it doesn't scroll. I'm lost here, I really have no idea what to do. Any help would be awesome.

I'm not very good at this so I'm probably missing something.

share|improve this question

closed as off-topic by Eric Carvalho, karel, Sneetsher, Warren Hill, BuZZ-dEE May 13 at 19:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
You seem to have a Logitech M505 mouse, is that correct? What happen if you unplug the Unifying receiver? (I know it sounds crazy, but perhaps the touchpad gets disabled when a mouse is connected) –  Lekensteyn Aug 24 '13 at 22:28
    
I forgot to mention I've already tried that. –  Robert Aug 24 '13 at 22:29
    
Same for me. Touchpad didnt work on ubuntu 12.04, but was recognized in settings tab. I've just upgraded to ubuntu 12.10, and it's still not working, and I even don't see it anymore in settings tab. But i can see that : SATELLITE-U840T:~$ xinput --list ⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ Dexin Corp. Saitek Game Mouse id=9 [slave pointer (2)] ⎜ ↳ eGalax Inc. eGalaxTouch EXC7910-1018-05.00.00 id=11 [slave pointer (2)] ⎜ ↳ PS/2 Synaptics TouchPad id=13 [slave pointer (2)] ⎣ Virtual core keyboard id=3 [master keyboard (2)] ↳ –  user274872 Apr 27 at 9:00