Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Wubi on a Dell Inspiron, and am trying to install the drivers for a Broadcom BCM4312 driver. I know this is a common question on the site, but I think I have tried every solution posed, and I still cannot get it to work. When I go into the jockey file, I get:

2013-08-24 17:10:10,049 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

I went into the blacklist.conf file and commented out

# blacklist bcm43xx

And I have restarted, even done a fresh install of Wubi. Nothing works. Any suggestions? Let me know know what further info I need to provide.


Based on request for further feedback, I ran this command:

lspci --n -d 1434:

And got the response:

0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

For further information, I uninstalled wubi and installed Ubuntu 12.04 on a new partition of my hard drive (I thought that might help with the driver issues), but I'm having the same problem.

I am able to connect an ethernet cable to get internet directly onto the machine. And, when I had Wubi installed in a previous installation on the same machine, I was able to somehow get the wireless to work, so I'm pretty sure it can be done.

share|improve this question
    
For jockey to work, it needs an active internet connection, was it available? –  mikewhatever Aug 24 '13 at 21:30
2  
Please edit your question to add details of your wireless card from the terminal command: lspci -nn -d 14e4: –  chili555 Aug 24 '13 at 21:44
    
Better would be to read the answers here the first and the second (from top to bottom) and add some additional info to your question. –  NikTh Aug 24 '13 at 23:08

1 Answer 1

Unfortunately, this is a bug reported years ago https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/511379

This is what you can try

Solution 1

sudo apt-get install --reinstall bcmwl-kernel-source

Reboot

Solution 2

Remove bcm-kernel-source, if present

sudo apt-get purge bcm-kernel-source

Make sure you got this installed (otherwise, install it)

sudo apt-get install firmware-b43-installer b43-fwcutter

Then, run

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl| lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3 |rt6|rt7|witch|wl'

If you see something like this

blacklist bcm43xx

Then

sudo gedit /etc/modprobe.d/blacklist.conf

If you don't have this anymore, then add the # again, to look like this

# blacklist bcm43xx

Reboot

Keep in mind that this is a unfixed bug, so neither of these solutions might work for you.

share|improve this answer
    
I believe bcmwl-kernel-source is incorrect for his device. We need the identifier 14e4:43?? before we know for sure. –  chili555 Aug 24 '13 at 22:04
    
Yes, you're right. I started looking for solutions to this problems, and bcmwl-kernel-source appeared in all of them. –  0R10N Aug 24 '13 at 22:25
    
...but the bug report was filed against BCM4311, and not BCM4312. I've been using BCM4312 802.11b/g LP-PHY [14e4:4315] with the STA driver for years, while b43 has been buggy. –  mikewhatever Aug 25 '13 at 8:54
    
chili555, I added further information in my answer above. any suggestions? –  linux_guest Sep 8 '13 at 17:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.