Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Am beignner to Linux world. Tried to dual boot ubuntu along side preinstalled windows 8 in my samsung series 5 np550pc s03in Laptop.

I have followed this guide - http://askubuntu.com/questions/22183...uefi-supported and based on the video, i have created a swap space and Ubuntu OS Space.

I have disabled Secure Bootloader and Booted in CSM. Everything went fine, ubuntu 12.10 installed fine and after restart, it doesnt booted up the ubuntu as well as Windows. Just a blank screen displays.

After restarting Ubuntu via LiveCD, I selected Try Ubuntu and installed Boot-repair. But still have booting problem.

Here is the pastebin link from boot loader -

http://paste.ubuntu.com/6022524

Also, Please advice how much space should i allocate for Swap? I am going to allocate 200GB for Ubuntu and Hence advice the corresponding SWAP Size.

share|improve this question

2 Answers 2

I think you installed Ubuntu using EFI which I have always had problems with. Insert the Windows 8 disk and boot the computer up. Boot into the BIOS by repeatedly pressing F8, Delete, or Insert (depending on the computer). Then find the option to force boot into the Windows 8 CD. Select that option. On the disk select "Repair computer" or something like that, then select "Troubleshoot," from the advanced options run the Command Prompt and type bootrec.exe /fixmbr. Reboot the computer and you should be able to boot into Windows. From there, format the Ubuntu OS partition. Then burn a non EFI version of Ubuntu to the USB drive you are using. Depending on the computer, boot into the BIOS by repeatedly pressing F8, Delete, or Insert when the computer is booting up. Find an option to force boot and boot into the USB drive without EFI. Install Ubuntu like normal and you should be fine.

share|improve this answer
    
Thanks for your Help. I can boot into windows by disabling the secured Boot loader and Selecting "UEFI" os type instead of "CSM/UEFI or CSM" –  Cyborgz Aug 24 '13 at 21:48
    
Ah. Sorry. I didn't know Windows 8 uses EFI. Maybe this tutorial will help? help.ubuntu.com/community/UEFI –  Kenneth Clark Aug 24 '13 at 22:08

First, the easy question: Your swap partition should normally be 1-2x your RAM size. So if you've got 4GiB of RAM, you'd want 4-8GiB of swap space. Today, most computers don't use swap much, except for the fact that it's used in suspend-to-disk operations, which require swap space to be at least equal to your RAM size.

As to your main problem, I recommend you try creating a USB flash drive or CD-R with my rEFInd boot manager. The download page includes links to versions for both types of media. If you can boot to the rEFInd menu, it will probably show you at least three options:

  • One for Windows
  • One for GRUB (EFI\ubuntu\grubx64.efi), which might boot through to Ubuntu
  • One for Linux (boot\vmlinuz-3.5.0-17-generic), which will probably boot Ubuntu

There may be additional options, too. Try them all. If you can boot both Windows and Linux (via GRUB or not), try installing the rEFInd Debian file from Ubuntu. With any luck, that will get you booting regularly via rEFInd. If not, try launching Windows, opening an Administrator's Command Prompt window, and typing bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi. This should set rEFInd as the default boot loader.

If even that doesn't work, try booting to Linux and moving /boot/efi/EFI/Microsoft/Boot/bootmgfw to /boot/efi/EFI/Microsoft/bootmgfw.efi -- that is, move bootmgfw.efi down one level. This will move Microsoft's boot manager out of the way so that the firmware won't find it. (Some EFIs are broken and try to boot Windows first, no matter what you tell them to do.) You may also need to type sudo mvrefind.sh /boot/efi/EFI/refind /boot/efi/EFI/BOOT, which moves rEFInd to a fallback position that normally works on any computer, even if the firmware can't remember what you tell it about your boot loaders.

share|improve this answer
    
Thank you so much for your response. Very helpful and informative. –  Cyborgz Aug 25 '13 at 11:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.