Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an old that sits and does some of the grunt work in the house. I've recently got it running 12.04 from 10.x, and everything seems to be working brilliantly.

Unfortunately though, it only seems to boot to the GUI when a screen is attached, and drops to TUI when there isn't. Since I mostly log into it via RDP, I'd rather it booted to GUI regardless of whether it has it's own screen plugged in or not.

Is there a setting I can change somewhere to disable TUI boot?

share|improve this question
add comment

1 Answer 1

You can try the command startx or sudo service lightdm start (whichever works) after logging in to start a GUI. If the startx this doesn't exist you should install it by sudo apt-get install ubuntu-desktop.

To start it at login, you could add a .desktop file to /xdg/etc/autostart to run the command.

From here: http://askubuntu.com/a/202274/176889

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.