Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am facing a bizarre problem recently in Ubuntu 12.04 while adding a new user. User adding command such as useradd -d /home/username -s /bin/bash -m username in the terminal only creates a example-ubuntu folder in the user's home but not the Downloads, Documents, Pictures, Music, etc.

Note that just before this, I had a problem with "login" probably due to interrupted ubuntu updating. So, I fixed the problem by:

  1. re-installing "ubuntu-desktop"
  2. re-configuring "lightdm"
  3. installing "unity and unity-2d" by searching Ubuntu blogs. Now login problem is fixed, but useradd is not.

So, I would really appreciate any help in this matter if anyone knows.

Mahboob

share|improve this question
add comment

1 Answer 1

sudo adduser <username>

Try that instead of useradd.

Make sure it's on

sudo sed -i s/enabled=False/enabled=True/g /etc/xdg/user-dirs.conf
share|improve this answer
    
Thanks for your reply. I tried adduser but unfortunately, I get the same result as before. To be noted, before my "login failure" problem "useradd -d ... ... ..." just worked so fine. –  user186889 Aug 24 '13 at 15:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.