Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried two emulators and Megaman 2 has issues running on GFCE Ultra NES Emulator where Megaman disappears when hit. GCEUX has sound problems.

share|improve this question
Did you try changing ROM? Does your ROM work flawlessy on another emulator (and operating system)? Also tweaking your emulator configuration can make a HUGE difference. – Pitto Apr 5 '11 at 16:55

Since youve already tried those 2, I would recommend fceux. ITs from the same "family" of emulators youve tried, but a different branch. And its in the official repositories. Maybe they have fixed your sound issue.

share|improve this answer

Try RockNES

share|improve this answer
i got it and extracted it, 'rocknes' is executable but clicking it does nothing. – neil Apr 5 '11 at 18:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.