Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the following file at /etc/X11/xorg.conf.d/11-TECK-keymap.conf

Section "InputClass"
  Identifier "TECK"
  Driver "evdev"

  # If you save this file under xorg.conf.d/ :
  Option "AutoServerLayout" "on"

  MatchIsKeyboard "on"
  MatchProduct "TrulyErgonomic.com Truly Ergonomic Computer Keyboard"

  ### at-home-modifier options begin here.
  # The basic option.
  Option "XkbLayout" "us"
  Option "XkbVariant" "altgr-intl"
  Option "XKbOptions" "lv3:ralt_switch_multikey,numpad:pc,ctrl:swapcaps"
  Option "TransMod" "36:64"
EndSection

I know that MatchProduct is correct, as Option "TransMod" (the at-home-modifier option) works on this specific keyboard. However, the Xkb lines don't work, unless I comment out the MatchProduct line.

I've found that (with MatchProduct present) the Xkb lines are being overwritten by /etc/default/keyboard. I've tried deleting this file, and commenting it out, but I still cannot get the xorg xkb options to stick.

(P.S. I'm using KDE, but "Configure layouts" and "Configure keyboard options" are unchecked in System Settings.)

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.