Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When starting tor-browser I get a error window stating the message below:

Vidalia detected that the Tor software exited unexpectedly. Please check the message log for recent warning or error messages.

Logfiles showing errors:

[Warning] /usr/bin/tor-browser/Data/Tor is not owned by this user (MYUSERNAME, 1000) but by root (0). Perhaps you are running Tor as the wrong user?
[Warning] Failed to parse/validate config: Couldn't access/create private data directory "/usr/bin/tor-browser/Data/Tor"
[Error] Reading config failed--see warnings above.

Am not allowed to run tor-browser as root, i tried purging it, and reinstalling it again, but same error.

I installed tor-browser with the following commands:

sudo add-apt-repository ppa:upubuntu-com/tor64 
sudo apt-get update 
sudo apt-get install tor-browser 

Question: How do i get tor-browser to work again?
Note: Am Running Ubuntu 13.04 amd64

share|improve this question

1 Answer 1

up vote 0 down vote accepted

After the installation is finished, set the right ownership on the ~/.tor-browser:

sudo chown -R $USER ~/.tor-browser
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.