Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When PC is booting I see next message:

the disk drive for /media/sdb1 is not ready or not presented
Continue to wait or Press S to skip mounting or M for manual recovery

I'm newly at ubuntu and don't know well about how it works with eternal usb drives. (sdb1 is this one).

Here is content of sudo fdisk -l:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e28b8

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   310484991   155241472   83  Linux
/dev/sda2       310487038   312580095     1046529    5  Extended
/dev/sda5       310487040   312580095     1046528   82  Linux swap / Solaris

Disk /dev/sdb: 4009 MB, 4009754624 bytes
16 heads, 32 sectors/track, 15296 cylinders, total 7831552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd8e1f237

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          32     7831551     3915760    b  W95 FAT32

Disk /dev/sdc: 993 MB, 993001472 bytes
2 heads, 1 sectors/track, 969728 cylinders, total 1939456 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1             133     1939455      969661+   6  FAT16

And here content of /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc  nodev,noexec,nosuid       0  0  
# / was on /dev/sda1 during installation
UUID=5f5d330f-d5f2-4157-9496-94f1dce2f181  /               ext4  errors=remount-ro         0  1  
# swap was on /dev/sda5 during installation
UUID=84747ef4-6f50-49bc-9df1-fcba364ba299  none            swap  sw                        0  0  
/dev/fd0                                   /media/floppy0  auto  rw,user,noauto,exec,utf8  0  0  
/dev/sdc1                                  /media/sdc1     vfat  uid=nazar_art             0  0  
/dev/sdb1                                  /media/sdb1     vfat  uid=nazar_art             0  0  
/dev/sdd1                                  /media/sdd1     vfat  uid=nazar_art             0  0  

- Why this exactly happen?
- How to solve this trouble?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I don't know why you have /dev/sdb1 in your fstab, but I know why you see that error at boot:

While booting, the kernel does a mount -a which looks at the fstab and tries to mount all the filesystems, but apparently your drive isn't present at the moment of mounting or you are using an incorrect module.

So to prevent this, you could either:

  1. Delete/comment the line:

     #/dev/sdb1    /media/sdb1    vfat    uid=1000    0    0
    
  2. Add noauto as mount option:

    /dev/sdb1    /media/sdb1    vfat    uid=1000,noauto    0    0
    
  3. Change the entry for a label or UUID:

    UUID=AA64B45A64B42AC9    /media/sdb1    vfat    uid=1000    0    0
    
  4. Use auto instead ofvfat:

    /dev/sdb1    /media/sdb1    auto    uid=1000    0    0
    

You should make user that the /media/sdb1 directory exists. Notice that for each line I changed the uid to the UID of the username. You should verify your own using:

cat /etc/passwd | grep braiam
braiam:x:1000:1000:braiam,,,:/home/braiam:/bin/bash

My uid is 1000.

I would love to ask why so many entries in fstab, but will keep my curiosity for myself.

share|improve this answer
    
I can't understand one point. At 2 step you suggest adding noauto as follows /dev/sdb1 /media/sdb1 vfat uid=1000,noauto .. and at 4 step use auto instead vfat as /dev/sdb1 /media/sdb1 auto uid=1000 .. And now my fstab looks next. I want to know if I did all steps as you recommended? Coz I feel that miss smt... –  nazar_art Sep 23 '13 at 12:50
    
I gave you 4 options, not 4 steps. You could use any of them but not all of them at the same time. The first line describe what they do according to your question. –  Braiam Sep 23 '13 at 13:02
add comment

The uid should be a number, not a name.
It's the first number after the username in the /etc/passwd file. At least, that's what the docs say.

  • Look up the number for the user in the /etc/passwd file, and edit the /etc/fstab file, replacing the user name with the number.
share|improve this answer
    
How to fix this issue? –  nazar_art Aug 23 '13 at 21:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.