Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to the Kubuntu Natty Beta 1 and I've been having a lot of issues with the process kworker. At moments it uses almost half my CPU. Also, strangely enough it seems to affect my USB ports; whenever I plug in an USB drive, the process kworker goes into hyperdrive, leaving me unable to work.

I have thought about filing a bug but since I haven't even found any reasonable explanation on what kworker is I figured I should find out first.

share|improve this question
    
Strange, kworker is running and contributing to the wakeups by 10% but I have no Kubuntu programs installed. Alos Nepomuk isnt installed. –  dago Jun 9 '11 at 21:16
    
from the response of afrazier i think now that it has something to do with the kernel (so the k in kworker is for kernel). so that is why you would also have kworker running on your Ubuntu machine. –  davorao Jun 11 '11 at 7:12
    
This answer may also be helpful for finding out what a kworker is doing: unix.stackexchange.com/questions/22851/… –  anarcat Feb 19 '13 at 4:08

7 Answers 7

up vote 41 down vote accepted

"kworker" is a placeholder process for kernel worker threads, which perform most of the actual processing for the kernel, especially in cases where there are interrupts, timers, I/O, etc. These typically correspond to the vast majority of any allocated "system" time to running processes. It is not something that can be safely removed from the system in any way, and is completely unrelated to nepomuk or KDE (except in that these programs may make system calls, which may require the kernel to do something).

There were some reports of excessing kworker activity for relatively idle systems starting during 2.6.36 development ( https://lkml.org/lkml/2011/3/29/2 is one example discussion ), and wide reports of confusion and problems with 2.6.38 (although many of these reports include the word "Natty", so I presume these people not to have used any kernel between 2.6.35 (distributed in Ubuntu 10.10) and 2.6.38 (distributed in Ubuntu 11.04).

I've found many reports of something that "fixed" this for one or another user. Most "fixes" seem to be related to updates of the kernel of various sorts. Where the update can be tracked to a specific issue, it seems to often be some driver or kernel service that has been patched to not misbehave: I have the impression that there are a very large number of things in the kernel that can cause a behaviour which is observed as excessive kworker usage.

If you find the system unusable due to excessive kworker activity, I would recommend trying to do fewer things. If you think you're not doing anything, try shutting down long-running services or timers (RSS readers, mail readers, file indexers, activity trackers, etc.). If this doesn't work, try restarting. If your system allows you to enable or disable hardware in a preboot environment, try turning off hardware you aren't using. If it happens on every restart before you do anything, you could try uninstalling things, but at this point you'll want to be running syscall profiling tools to track down specific applications that seem to be causing this overload.

It is to be hoped that your specific system will stop expressing this behaviour with a future kernel upgrade (and many of the most common causes of this have been solved).

share|improve this answer

Why does kworker hog your CPU (cont.)? In addition to my other answer here, Perf is a more professional way to analyse what kernel tasks are hogging your CPU:

  1. Install perf:

    sudo apt-get install linux-tools-common linux-tools-3.11.0-15-generic
    

    (The second package must match your kernel version. You can first install just linux-tools-common and call perf to let it tell you which package it needs.)

  2. Record some 10 seconds of backtraces on all your CPUs:

    sudo perf record -g -a sleep 10
    
  3. Analyse your recording:

    sudo perf report
    

    (Navigate the call graph with , , , and Enter.)

share|improve this answer

What is kworker? kworker means a Linux kernel process doing "work" (processing system calls). You can have several of them in your process list: kworker/0:1 is the one on your first CPU core, kworker/1:1 the one on your second etc..

Why does kworker hog your CPU? To find out why a kworker is wasting your CPU, you can create CPU backtraces: watch your processor load (with top or something) and in moments of high load through kworker, execute echo l > /proc/sysrq-trigger to create a backtrace. (On Ubuntu, this needs you to login with sudo -s). Do this several times, then watch the backtraces at the end of dmesg output. See what happens frequently in the CPU backtraces, it hopefully points you to the source of your problem.

Example: e1000e. In my case, I found a backtrace like this nearly every time:

Call Trace:
 delay_tsc+0x4a/0x80
 __const_udelay+0x2c/0x30
 e1000_acquire_swflag_ich8lan+0xa2/0x240 [e1000e]
 e1000e_read_phy_reg_igp+0x29/0x80 [e1000e]
 e1000e_phy_has_link_generic+0x85/0x120 [e1000e]
 e1000_check_for_copper_link_ich8lan+0x48/0x930 [e1000e]
 e1000e_has_link+0x55/0xd0 [e1000e]
 e1000_watchdog_task+0x5e/0x960 [e1000e]

It hinted me to a problem in the e1000e Ethernet card module, and indeed a sudo rmmod e1000e made the high CPU load go away immediately [e1000e bug #26].

share|improve this answer

Just to let everyone know. I ran into this issue, installed perf (which is a great tool), it pointed to spin locking and XFS. That pointed to NFS. Then I realized one of my mounts was out of space. Freeing up space caused kworker CPU to drop to 0.

So apparently this can be a symptom of running out of drive space on a busy NFS server!

share|improve this answer
    
I noticed I had a kworker meltdown when a specific virtualbox was running. Turns out that one was running an NFS with my host for sharing files. However it was nowhere near full. Unmounting the NFS "resolved" the issue. I guess I'll share with an sshfs mount. –  Programster Apr 22 at 17:57

I recently installed Ubuntu Natty on an external drive usb wd passport. When I start on my desktop which is about two years old, everything works like a charm. When I start on my new laptop (MSI gt680r system), it slows down after I wake up the computer from sleep, or if I plug another usb disk.

Kworker processes take more and more cpu, and the mouse freezes from time to time.

I have read several solutions on various forums that did not work.

I went into the bios of my laptop, where there was:

Hand XCHI OFF: Enabled
EHCI Hand OFF: disabled

I changed for:

Hand XCHI OFF: disabled
EHCI Hand OFF: disabled

and since that, it doesn't freeze anymore on natty on my laptop.

I would enable hand back if and when the problem is corrected.

share|improve this answer

I think disabling Nepomuk can help you:

http://www.freetechie.com/blog/disable-nepomuk-desktop-search-on-kde-4-4-2-kubuntu-lucid-10-04/

share|improve this answer
    
thanks but I've since installed a fresh copy of Kubuntu 11.04 and the before-mentioned problem disappeared. –  davorao May 6 '11 at 18:32
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Mar 7 at 10:37

On Mac OS X, mdworker is the Spotlight indexing service. So Kworker might be some indexing engine for a system wide search.

share|improve this answer
    
I also assumed that it has something to do with kde(the k and all), but I've found no evidence of it anywhere online. And I've also been unable to find any documentation on it whatsoever. –  davorao Apr 5 '11 at 14:39
3  
@davorao: The k may indicate kernel. –  afrazier Jun 10 '11 at 0:39
    
that may be the best answer i've gotten so far. I've also forgotten about it since Kubuntu 11.04 came out and solved my problem for me. But i would assume that it probably has something to do with the kernel. –  davorao Jun 10 '11 at 19:00

protected by Seth Aug 14 at 3:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.