Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had Lucid Lynx (I think that's ubuntu 10.4LTS) running on VirtualBox V4.2. for about 6 moths already running on Win7 host OS. I've never had any issues with internet connectivity so far, but today afternoon it just stopped working without any apparent reason. I'm on my laptop and win7 still connects to the internet. I can see the 'Virtualbox Bridged Networking Driver' in the wireless network properties on my host OS. So far I only needed internet access so I used NAT (adapter type: INTEL PRO/1000 Desktop with cable connected option enabled), however all I receive in return is 'Networking disabled'. In terminal ifconfig -a returns:

eth2      Link encap:Ethernet  HWaddr 08:00:27:76:54:26  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:44 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 

         RX bytes:3152 (3.1 KB)  TX bytes:3152 (3.1 KB)

In terminal iwconfig returns lo eth2 no such extensions. Ping-ing any address returns Network is unreachable except when I ping what it says is my ip adress (which is also weird 127.0.0.1). As I was reading up on the problem I've noticed that a lot of people solved their problem by simply changing their adapter type so I did that multiple times (for various versions of PCnet-FAST II/III and the aforementioned Intel Pro/1000) but without result. I've also tried using 'Bridged adapter' with different names and adapter type options also without result. my etc/network/interfaces file looks like:

auto lo
iface lo inet loopback

which resembles this problem but when I try using his solution:

ubuntu-admn@ubuntu:~$ sudo dpkg-reconfigure resolvconf
Package `resolvconf' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: resolvconf is not installed
share|improve this question
    
If 10.04 is the Desktop version it is considered EOL (End of Life) and your question probably will be deleted as per. Please consider upgrading to a newer version of Ubuntu. –  Stef K Aug 23 '13 at 18:47

1 Answer 1

Try changing the network from NAT to bridged. This will put the VM directly on your network and allows you to select which underlying network adapter you want to share.

iwconfig won't help with guest OS because the virtual machine hides the fact that you are using wireless. The guest OS thinks it is connected to the network using a wired connection.

Edit: After using a bridged connection, on the guest os try this:

dhclient eth2
share|improve this answer
    
"I've also tried using 'Bridged adapter' with different names and adapter type options also without result". Anything else you can recommend except just bridged? –  ljetibo Aug 24 '13 at 9:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.