Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a fresh install of Xubuntu 12.04 and I'd like to know how can I activate my nVidia card's GPU acceleration inside the latest stable Chromium. I wanted to play an MP4 file without the CPU firing to 100%.

I've installed mplayer and vdpau (and they work fine), but so far I haven't been able to use them inside Chromium. A couple of years ago, I used gecko-mediaplayer but the plugin's been blacklisted...

Any ideas?

Here's the output of glxinfo | grep render:

direct rendering: Yes
OpenGL renderer string: GeForce GT 520M/PCIe/SSE2
    GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 

and here's the output of lspci | grep -i vga:

02:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520M] (rev a1)

Chromium is churning out a lot of warnings whenever I open the page, as you can see here and I've just found out a promising lead, lost in a sea of performance warnings:

NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).

After adding the user to the video group, Chromium is now unable to play MP4's at all (yup, not even using the CPU). I got the same error messages as before, but a new one popped up as well:

[4296:4296:0827/100001:ERROR:gpu_video_decode_accelerator.cc(208)] Not implemented reached in void content::GpuVideoDecodeAccelerator::Initialize(media::VideoCodecProfile, IPC::Message*)**HW video decode acceleration not available**.
share|improve this question
    
Why does your CPU usage rise to 100%? Even without any HWA (no GPU), I can play mp4 videos through Google Chrome and the CPU usage is < 20%. –  user25656 Aug 23 '13 at 16:52
3  
1080p videos on a 4 year old, 300$ computer. –  Hal Aug 26 '13 at 8:32
add comment

1 Answer 1

up vote 5 down vote accepted
+100

TL;DR: Unless you have tried everything below and now you get a black screen hitting this particular fixed bug, your problem should be solved by now. If you now get:

ERROR:gpu_video_decode_accelerator.cc(208)] Not implemented reached in void content::GpuVideoDecodeAccelerator::Initialize(media::VideoCodecProfile, IPC::Message\*) HW video decode acceleration not available.

after trying everything below, then you should try starting Chrome/ium with --disable-gpu-sandbox or --blacklist-accelerated-compositing. If problems persists, revert all changes and report a bug detailing what is your problem, what have you tried, and all the data possible: about:gpu, about:version, the drivers you are using, kernel version, etc. For the ones that still want to test their luck, use the switch mentioned earlier, does that are having issues with AMD cards, the "Forcing Chrome/ium to use HWA" section works for you. Those using Nvidia privatives drivers or the xorg-ppa-edge, should test with Firefox and see if the issue happens there too.

Nvidia permissions problems

NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).

This means that you are not part of the video group. This is solved as easy as you could be:

sudo adduser Hal video

Then restart your session and you are there.

Source: http://forums.gentoo.org/viewtopic-p-7232328.html?sid=900a2d59cdb52e1a5f530598dfa1be24#7232328

Forcing Chrome/ium to use HWA

You should check your about:gpu section in Chrome/ium. In older PC's HW Acceleration is disabled by default and you only can enable it by overriding the settings in the about:flags.

  • Open the about:flags in your address bar
  • Look for Override software redendering list
  • Click "Enable"
  • Restart Chrome/ium

You can also start chrome using chrome --ignore-gpu-blacklist but having to do so each time is not ideal.

This is my GPU page

THis is my flags

share|improve this answer
1  
Well, I enabled the "override software rendering list" in chrome://gpu, reopened chromium and opened a local page containing an HTML5 embed video tag (the source is an MP4) but the CPU is still doing well over 100%. Then, I installed gecko-mediaplayer, rebooted and reopened chromium with the ignore blacklist parameter but no such luck as well. Any other ideas? My graphic features status is identical to yours. –  Hal Aug 23 '13 at 16:09
    
I'm not sure if video decoding is actually working. I'm running Chrome 29 on Ubuntu 12.04 and I see "Accelerated video decode is unavailable on Mac and Linux.: 137247, 133828", so I'm surprised to see you got it to "Hardware Accelerated". –  gertvdijk Aug 26 '13 at 10:43
    
Now, if only we could make Chromium put his money where his mouth is... –  Hal Aug 26 '13 at 11:23
1  
@Braiam Sorry if I wasn't really clear - it shows it for me as well, but it seems it isn't working as shown in the "problems detected" output (when disabled forcing options). See also the bug report (code.google.com/p/chromium/issues/detail?id=137247) –  gertvdijk Aug 26 '13 at 13:06
1  
@gertvdijk Yeah, I've seen that report before. Actually is a pretty darn dumb policy: We don't like bug reports, so we (really) slowly activate the cards we believe don't have problems (which are the minority) and leave the users that have cards that might work just fine run with just 0.1% of their real performance. –  Braiam Aug 26 '13 at 19:29
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.