Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with quick launch keyboard buttons on hp probook 4310s and ubuntu 10.10. Actually, with one button- Wi-Fi on/off

In windows everything works fine, but in Ubuntu every time I turn to network and make some actions (e.g., it's happening while I'm writing this message) this button goes crazy. It starts blinking. If I just read the page-it doesn’t blink. There are no pop-up messages like “Wi-Fi connected/Wi-Fi disconnected/Wi-Fi conn…”. But network connection blinks in the company of the button.

If I try xev, the event tester doesn’t show anything-it seems I don't push it. If I try to make a new action in keyboard shortcut settings- it doesn't see I push this button in a hope to change it's assignment. Despite of this the button works. Sometimes, when it's not blinking I can push it and it changes it's colour- so, somehow it works. How can I configure this button or the whole panel? Or what driver I must install manually?

share|improve this question

many thanks to Tux he wrote:

gksudo gedit /etc/modprobe.d/wlan.conf Then put in the following content:

options iwlcore led_mode=1

Restart and it should work. Taken from gentoo wiki.

share|improve this answer

Tip from another forum, which worked perfect for me after the quick launch buttons gave up their function from one day to another:

remove the power cable, shutdown your laptop, remove the battery, then hold the power button of your laptop for 15 seconds and then insert the battery and restart again.

After that weird procedure my quick launch buttons worked again. It seems like magic :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.