Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 13.04 alongside Windows 8. Ever since then, I'm not able to put my computer to sleep in Windows 8. I click sleep, and it goes black, then just turns back on. After some digging, I found this thread (http://ubuntuforums.org/showthread.php?t=1341694) from a few years ago. I followed the instructions the guy suggested, but it didn't work. Was I supposed to remove the boot flag from the Ubuntu partition as well? Any ideas?

I've tried using EasyBCD to make Windows 8 my default, but it didn't work. As far as I understand, the reason Windows refuses to sleep is that it's not the primary boot drive or something.

share|improve this question

1 Answer 1

You need to actually remove the boot flag from the Ubuntu partition and put it on Windows instead.

To do this, boot to any Live session that has GParted (Ubuntu, EasyBCD, etc.) Open GParted and right-click the Ubuntu partition, select "Flags", and uncheck the "boot" flag. Upon return to the main GParted UI, right click the Windows 8 partition and select "Flags", then check the "boot" flag.

Apply with the button with the green check mark, reboot, and you're done (hopefully).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.