Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this might look like a repeated question
but I've been looking for a solution everywhere I could think of with no success

I am using a Dell Inspiron N5110
It has intel shared graphics and an nVidia GeForce GT 525M graphics card
Running Ubuntu 13.04 64-Bit

Which is very bad for some reason

anyways,
I installed drivers for the nVidia card from the Xorg Edgers
Huge mistake
because now, unity won't appear
I can only see my desktop and the files on it
which sucks because I can't really run any programs
The only reason I'm able to use Chrome to write this is because I have an html page on the desktop
I open it, then it opens in chrome
other than that, the launcher and top bar are gone
I can only close chrome by closing all tabs
and have to shutdown from terminal

I installed bumblebee, nvidia drivers
removed them
reinstalled them again
NOTHING CHANGED

I AM STILL UNABLE TO USE UNITY

I know someone somewhere has a solution other than reinstalling ubuntu
Can you please help me internet?

UPDATE:
I have used the following commands
dconf reset -f /org/compiz/
unity --reset-icons &disown
to get unity to reappear
the launcher doesn't have my old icons, it has the default ones
and when I run it through the terminal, it produces a giant list of errors
I don't want to have to run this every time I start Ubuntu!!

share|improve this question
add comment

4 Answers 4

Unfortunately the unity --reset does not work any longer as it has been deprecated.

I have found this project in Github that may be a solution to your problem: https://github.com/phanimahesh/unity-revamp

Download the file unity-reset.py to a folder then execute it in a terminal with the following command python unity-reset.py.

Give it a try.

share|improve this answer
    
$ python unity-reset.py File "unity-reset.py", line 4 <!DOCTYPE html> ^ SyntaxError: invalid syntax –  Black ExS Aug 23 '13 at 13:59
add comment

I think you should remove all those ppa with the ppa-purge to clear all the packages they installed.

sudo apt-get install ppa-purge

and then

sudo ppa-purge ppa:example

Reboot and install again the Nvidia drivers that Ubuntu additional drivers list. Staying with the drivers Ubuntu offer is the best solution.

share|improve this answer
    
Before, nothing appeared in the additional drivers tab.. I can't look in it now because I can't figure out how to access it.. will try and post results –  Black ExS Aug 23 '13 at 14:01
add comment
  1. You have to install and launch the compiz config setting manager (ccsm):

    sudo apt-get install compizconfig-settings-manager
    sudo ccsm

  2. check OpenGL

  3. click on Ubuntu Unity Plugin
  4. check activate Unity plugin in the left margin
    you'll then be requested to activate other plugins and resolve some keyboard shortcuts

Et voilà, the unity menu bar and launch bar will appear.

Note : you should select to use NVIDIA drivers by using the control pannel -> Software and update -> additional drivers. I selected the top most radio button. (I'm translating from french, so the names may not be exactly the one you see.)

share|improve this answer
    
That's the weird part, it never appeared in there there was nothing in the additional drivers tab before and I can't access it now also, I tried this and it didn't work –  Black ExS Aug 23 '13 at 13:56
    
There still is nothing in the additional drivers tab, I removed the ppa's that I added.. but it still won't show me my nvidia card or allow me to get my old launcher icons back –  Black ExS Aug 23 '13 at 14:24
    
Maybe you confused apt by your attempts. In my case installing Ubuntu desktop 13.04 from scratch, the additional drivers showed up. Note that during installation I was asked if I agreed to use none open source programs and I checked yes. Maybe this is what is missing for you. I have this line active in my apt sources.list : deb extras.ubuntu.com/ubuntu raring main. Maybe it's there. partner was not active, so it's not there. –  chmike Aug 29 '13 at 12:56
add comment

If Nvidia drivers disappeared from "additional drivers" list, then you should try to install "nvidia-common"

sudo apt-get install nvidia-common

share|improve this answer
    
I did this, Unity didn't crash again.. but still nothing in the additional drivers tab, nor does it show up in the About System > Graphics –  Black ExS Aug 29 '13 at 6:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.