Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I managed to install Ubuntu 13.04 on HP Envy 15-J005SP but the grub menu does not show up and it boots directly to W8.

I've tried the following:

  • On installation I manually selected an unallocated partition choosing as a start point "\" - After installing, Ubuntu asks to reinitiate but the PC boots directly to W8. Made a few research and tried the work arounds on the official Ubuntu UEFI page, i.e. disable Secure boot and Intel Smart Technologies options on BIOS - Same result, still goes to W8.
  • Runned again LiveCD and reinstall Ubuntu on the same partition - Still nothing new;
  • Last action made and by using the Minitool partition magic, deleted the Ubuntu partition + swap partition. Runned the livecd and this time asked to install Ubuntu in parallel with W8(automatic option, did not choose any partition - Anyway the partition created is exactly the same as when I did manually) - Still the same result. As a last resort I tried the option of running Ubuntu by livecd without installing and to make a boot repair(http://paste.ubuntu.com/6007362). The tool detected some sort of buggy kernel and supposedly corrected it, but the PC stills boots directly to W8.

I noticed that by pressing F9 before boot I manage to select the Ubuntu partition and the Grub 2 menu shows up. I choose to start Ubuntu but the PC freezes and some errors occur. I want to upload an image showing the error but I don't know how to. If someone needs this image please tell me how to upload.

[Update] Using F9, grub 2 menu shows up and looking into 'Advanced Ubuntu" I finally managed to enter Ubuntu. Made a system update, reboot, choose the latest kernel and the PC crashes. Reboot again, some error messages appears, saying that some Unknown chipset is not detected but it goes throw and Ubuntu opens. Still when I reboot the system still enters directly into W8.

Anyone help to put grub 2 to appear automatically? Did anyone faced any entry error showing a similar message like Unknown Chipset ...?

Thank you.

Diogo

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.