Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an MSI GS70 laptop running Windows 8 and I'm attempting to dual boot Ubuntu alongside Windows 8. I'm following the directions to install Ubuntu in UEFI mode and have tried disabling SecureBoot and all that stuff. I don't think I can turn off Intel SRT because I currently run a RAID array and doing so would result in a loss of data for me.

Anyhow, onto the actual issue at hand. I can successfully select the USB drive as the primary boot device and I get to the page that asks whether I want to try Ubuntu or Install it or do the OEM option and so on. So I get that far, but when I select to try Ubuntu without installing, it goes to a black screen and it appears to quit reading from the USB stick and nothing is displayed on screen. Does anyone have an idea why this is happening?

Edit: I do want to add that my laptop has all USB 3.0 ports, if that makes a difference.

share|improve this question
    
There is a possibility that your USB stick has unreadable bits or your downloaded iso has CRC error, I think there is an option to check if data are sound or not at boot up. –  MusuNaji Aug 22 '13 at 15:52
    
I tried using the option to check for defects and the same thing happened. It stopped reading from the USB drive. My USB drive has a light that flashes when activity is being registered and the light just stops lighting up when no activity is being registered and that's what's been happening. –  Eric Aug 22 '13 at 18:01
    
possible duplicated Ubuntu 13.10 installer/live fails to boot from DVD/USB on UEFI –  Braiam Dec 8 '13 at 11:43
add comment

2 Answers 2

I just bought an MSI GS70, 2 ssd configuration. I managed to get Ubuntu 12.04.3 dual boot working, here are the steps I took.

  1. Access BIOS, either by hitting DEL while the computer is starting, or through Windows.

    • Set Secure Boot Control -> Disabled
    • Set Boot Mode -> Legacy
  2. Boot from the Ubuntu USB and proceed to install Ubuntu normally. Personally, I did the easiest thing I could and simply installed Ubuntu on a partition of the 1TB hard drive. This was to avoid dealing with Raid 0 hassles.

  3. At this point, even though Ubuntu had correctly installed, I couldn't boot into Ubuntu. I completed the remaining steps with the USB Ubuntu trial.

    This is still in Legacy mode:

  4. Restart your computer, hit DEL repeatedly to access the BIOS and switch the boot mode back to UEFI.

  5. Restart once again and hopefully you should see grub. Everything should be in working order.

Goodluck!

share|improve this answer
    
I have the same version of the MSI GS70. I'll follow your steps and hope it works right. I, too, was hoping to install it on the 1TB HDD instead of the SSD array. –  Eric Sep 12 '13 at 19:29
add comment

I have the exact same problem on my Toshiba Satellite S50-A. In my case the problem is definitely related to UEFI; if I configure the firmware for "CSM Boot", aka legacy BIOS mode, the USB drive boots normally.

The one partial solution that I have found is this: If I disable "Built-in LAN" in the setup utility, the Live USB will boot as expected in UEFI mode. Of course, then the ethernet adapter is completely disabled. In my case, I only use WiFi, so it is an acceptable sacrifice. (Thanks to user oldfred who provided this suggestion in response to my own question.)

I'm not sure why Built-in LAN is a problem or what is the proper solution.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.